summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-31 12:47:52 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-31 12:47:52 +0000
commitecef77aaf95fde52d802f3f0558ed5bd41d2afa7 (patch)
treeefca7d3f566f303f2906959dfe8e618189adef34 /app-shells
parentfixing #24290 (diff)
downloadgentoo-2-ecef77aaf95fde52d802f3f0558ed5bd41d2afa7.tar.gz
gentoo-2-ecef77aaf95fde52d802f3f0558ed5bd41d2afa7.tar.bz2
gentoo-2-ecef77aaf95fde52d802f3f0558ed5bd41d2afa7.zip
reorganizing ebuild
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/csh/ChangeLog4
-rw-r--r--app-shells/csh/Manifest4
-rw-r--r--app-shells/csh/csh-1.29-r2.ebuild25
3 files changed, 21 insertions, 12 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index 94c005fe521c..3ec275810939 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.8 2003/07/31 12:28:24 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.9 2003/07/31 12:47:40 taviso Exp $
*csh-1.29-r2 (31 Jul 2003)
@@ -10,6 +10,8 @@
fix printing of exisiting buffer after displaying completion options.
# 24290
+ re-organizing ebuild and seperating patching into src_unpack()
+
16 Jun 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r1.ebuild:
no outstanding bugs, several users have requested by email that this
be marked stable, so marking stable on x86 and alpha.
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index 7a87786d9d65..f90af1aca731 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,7 +1,7 @@
MD5 24974796f8712ee41f927e1e76ff5a70 csh-1.29.ebuild 3803
MD5 c9ed16e56100fb9511e19c7e00371705 csh-1.29-r1.ebuild 4060
-MD5 7f502c9056d0630197e165a4abb049e2 csh-1.29-r2.ebuild 4272
-MD5 fbaf3ed0733d749cda46c2515c7985f0 ChangeLog 1898
+MD5 00775d652bc2397997cf9c53532771da csh-1.29-r2.ebuild 4335
+MD5 b52762964210239aa0de2efc9e1a0179 ChangeLog 1964
MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
diff --git a/app-shells/csh/csh-1.29-r2.ebuild b/app-shells/csh/csh-1.29-r2.ebuild
index ff436f00c63b..b722ec8478bb 100644
--- a/app-shells/csh/csh-1.29-r2.ebuild
+++ b/app-shells/csh/csh-1.29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.1 2003/07/31 12:28:24 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.2 2003/07/31 12:47:41 taviso Exp $
inherit flag-o-matic eutils ccc
@@ -21,7 +21,10 @@ RDEPEND="virtual/glibc"
S=${WORKDIR}/src/bin/csh
-src_compile() {
+src_unpack() {
+ # unpack the source tarball
+ unpack ${A}
+
# hide some BSDisms, mostly my work, got some hints from the
# debian project (they use an older OpenBSD csh, though).
cd ${S}; epatch ${FILESDIR}/linux-vs-bsd.diff || die "patching failed."
@@ -62,13 +65,6 @@ src_compile() {
printf "\t\"DEBUG\",\n\t\"ERR\",\n\t(char *)0x0\n};\n\n" >> ${S}/signames.h
- einfo "Adding flags required for succesful compilation..."
- # this should be easier than maintaining a patch.
- for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
- do
- append-flags ${i}
- done
-
einfo "Making some final tweaks..."
sed -i 's#sys/tty.h#linux/tty.h#g' ${S}/file.c
sed -i 's!\(#include "proc.h"\)!\1\n#include "signames.h"\n!g' ${S}/proc.c
@@ -76,6 +72,17 @@ src_compile() {
sed -i 's!#include "namespace.h"!!g' ${S}/vis.c
sed -i 's#/usr/games/fortune#/usr/bin/fortune#g' ${S}/dot.login
+}
+
+src_compile() {
+
+ einfo "Adding flags required for succesful compilation..."
+ # this should be easier than maintaining a patch.
+ for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
+ do
+ append-flags ${i}
+ done
+
# maybe they dont warn on BSD, but _damn_.
export NOGCCERROR=1