summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-21 00:57:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-21 00:57:48 +0000
commitdae245f4efb93fba8432d973a6220df7708eb696 (patch)
treed6bbccd3e0528337d28bbe31dca5bd9ae63d64d1 /app-shells
parentVersion bump. (diff)
downloadgentoo-2-dae245f4efb93fba8432d973a6220df7708eb696.tar.gz
gentoo-2-dae245f4efb93fba8432d973a6220df7708eb696.tar.bz2
gentoo-2-dae245f4efb93fba8432d973a6220df7708eb696.zip
Version bump.
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-3.1_p14.ebuild150
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p1448
3 files changed, 204 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index a792267b827d..e8dc520ea460 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.89 2006/03/05 03:11:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.90 2006/03/21 00:57:47 vapier Exp $
+
+*bash-3.1_p14 (21 Mar 2006)
+
+ 21 Mar 2006; Mike Frysinger <vapier@gentoo.org> +bash-3.1_p14.ebuild:
+ Version bump.
*bash-3.1_p11 (05 Mar 2006)
diff --git a/app-shells/bash/bash-3.1_p14.ebuild b/app-shells/bash/bash-3.1_p14.ebuild
new file mode 100644
index 000000000000..d256bf02d6fb
--- /dev/null
+++ b/app-shells/bash/bash-3.1_p14.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p14.ebuild,v 1.1 2006/03/21 00:57:48 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+READLINE_VER=5.1
+READLINE_PLEVEL=1
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+# Hit the GNU mirrors before hitting Chet's site
+# printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+# ${MY_PV} ${MY_PV/\.} ${i}
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)
+ $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="afs nls build bashlogger"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ cd lib/readline
+ for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
+ done
+ cd ../..
+
+ # Fall back to /etc/inputrc
+ epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
+ # Add more ulimit options (from Fedora)
+ epatch "${FILESDIR}"/${MY_P}-ulimit.patch
+ # Fix a memleak in read_builtin (from Fedora)
+ epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+ # Fix -/bin/bash login shell #118257
+ epatch "${FILESDIR}"/bash-3.1-fix-dash-login-shell.patch
+# # Fix generation of signals list when cross-compiling
+# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.0-configs.patch
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #myconf="${myconf} $(use_with !readline installed-readline)"
+ myconf="${myconf} --without-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ export bash_cv_termcap_lib=libcurses
+ myconf="${myconf} --with-curses"
+
+ econf \
+ $(use_with afs) \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake -j1 || die "make failed" # see bug 102426
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/
+ [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ if use build ; then
+ rm -rf "${D}"/usr
+ else
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+}
diff --git a/app-shells/bash/files/digest-bash-3.1_p14 b/app-shells/bash/files/digest-bash-3.1_p14
new file mode 100644
index 000000000000..128e48f4dbfe
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.1_p14
@@ -0,0 +1,48 @@
+MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
+RMD160 cbeda56312b3f623684b2099b711bb7592e0eda1 bash-3.1.tar.gz 2533934
+SHA256 d6952b2c38f9bf417559dd3b071860e1099ddfb8a12c0228f22afaf47f79d3b9 bash-3.1.tar.gz 2533934
+MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
+RMD160 0d071aeade45c1706f4061774bb486d9a2ba7dae bash31-001 2708
+SHA256 3b6d9151ca7a45dbcf43ebd1c6a647ef90c4b8eb54a245936fd6ffadc61fe727 bash31-001 2708
+MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
+RMD160 9b03b62c9eb1ba2a574467c6a2950b3b933794e1 bash31-002 7169
+SHA256 ecd248b1ca027368dae967502af5b28019eeee8fa3ee8d6a0210677789658f08 bash31-002 7169
+MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
+RMD160 1ee18374c2416407d1fa997ed99c5fc7f295cd62 bash31-003 1324
+SHA256 96cb8a42162a5876b2392b76fbfc78d073f50735e1e8a14e67e03b6e9c2b215d bash31-003 1324
+MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
+RMD160 b8182116ca8efc0bec9054694cac54045245a704 bash31-004 1470
+SHA256 a50ecd3f51e9a79f34855c68c61c9523fccb66da0870eade936cc1f64ba04415 bash31-004 1470
+MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
+RMD160 3e2583ebf0e4fc546cdcf8ccf8b987a100f71a7e bash31-005 1322
+SHA256 3b057498f01cb2b528a154b9043261cb059846b23222409f7de95a7971dc6664 bash31-005 1322
+MD5 68a41a9da7c669b4358837d06556a06f bash31-006 1561
+RMD160 608f650ef96c6f0e46395a21d9e30aba42fb33f9 bash31-006 1561
+SHA256 d155030ed49de27812d9ae01211283f7afe5e718ea4ed9babe1f121d25acf778 bash31-006 1561
+MD5 f6ca4950256fefd88d49c5702338e501 bash31-007 3254
+RMD160 ae865a7f4e0cbeb2022004d385c7c9d29dfe07a5 bash31-007 3254
+SHA256 fa89a6c808490e07cd7350ecb3390ce0ae6dc71d634c61c62991aafab97962c4 bash31-007 3254
+MD5 4fd01140cb5875fe020939aab02791f0 bash31-008 1422
+RMD160 9ec2f72649a1955593ab4ad98605ba323747367a bash31-008 1422
+SHA256 c30fe9da56261c7100c5b6794d4341b6b1fb6aa0ecc25b1010ac4ac25b07d1c7 bash31-008 1422
+MD5 37aad0d5aa57881742ec6419faf9e480 bash31-009 2000
+RMD160 443ba0c4cbd81fe4a24d92f213a65c4dbf123053 bash31-009 2000
+SHA256 cfdc6dd92d0f47988ee59e2a26e8e62a87558e03908a26ee33dd0394228ac255 bash31-009 2000
+MD5 91c52d2a51d41d4b6907758952aa0554 bash31-010 5218
+RMD160 9228d25e84180f576892ee6c9c3da8262e201269 bash31-010 5218
+SHA256 7ba8186d5e7de76c5b4e7c8905ad82b3d7cf459141eedc4ebcc6a0ca3b23cfc4 bash31-010 5218
+MD5 37ace691fc4bd386fb764b5f53cde4a1 bash31-011 1462
+RMD160 1f35aeb50689b9ea1a8d393e34abbe1da241164a bash31-011 1462
+SHA256 09cfa96d03b4a12bb85687e61797214222e188c4002f51962dffa51ab12ed998 bash31-011 1462
+MD5 cd5d17f0729a6da39a60039f2730e408 bash31-012 1212
+RMD160 21892db3ca2441ebba7eabb269437024b37de0d1 bash31-012 1212
+SHA256 b28bf4a491658879c43d4150cf0be1c48db97a594b6657c1cdeceabc226b8231 bash31-012 1212
+MD5 31317d6a80bed2eb9b6fd3d12d304259 bash31-013 1133
+RMD160 da5aa550ac0f4a92346f846cd0e1d7290631f6a7 bash31-013 1133
+SHA256 8b9a49bd03994f789198269c80b544b04e9056973bd75f843c05e40873c97088 bash31-013 1133
+MD5 7f4aef181659265d822c48e774834975 bash31-014 2818
+RMD160 d627b92e82e6c850b8f6abf2f6828b8120f1a695 bash31-014 2818
+SHA256 48086c8572efebfab3535dfbd4767d95eaf98e7dcb7d1dd13698a16ab0580319 bash31-014 2818
+MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
+RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
+SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042