summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-13 13:09:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-13 13:09:44 +0000
commitd81af31cab0c4ba8317f37056a56688e1c4cb3d3 (patch)
tree6a02a1727ae0507f86e1d75fb61ee3a0e33a38ec /app-shells
parentJust a few cosmetic changes (diff)
downloadgentoo-2-d81af31cab0c4ba8317f37056a56688e1c4cb3d3.tar.gz
gentoo-2-d81af31cab0c4ba8317f37056a56688e1c4cb3d3.tar.bz2
gentoo-2-d81af31cab0c4ba8317f37056a56688e1c4cb3d3.zip
Cosmetics
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/esh/esh-0.8-r2.ebuild42
-rw-r--r--app-shells/esh/files/digest-esh-0.8-r21
2 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/esh/esh-0.8-r2.ebuild b/app-shells/esh/esh-0.8-r2.ebuild
new file mode 100644
index 000000000000..99088e94e20a
--- /dev/null
+++ b/app-shells/esh/esh-0.8-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r2.ebuild,v 1.1 2001/04/13 13:09:44 achim Exp $
+
+P=esh-0.8
+A=${P}.tar.gz
+S=${WORKDIR}/esh
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+SRC_URI="http://esh.netpedia.net/"${A}
+HOMEPAGE="http://esh.netpedia.net/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+
+src_compile() {
+
+ cp Makefile Makefile.orig
+ sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+ try make
+}
+
+src_install() {
+
+ dobin esh
+ into /usr
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ docinto html
+ dodoc doc/*.html
+ docinto examples
+ dodoc examples/*
+ insinto /usr/share/emacs/site-lisp/
+ doins emacs/esh-mode.el
+}
+
+
+
+
+
diff --git a/app-shells/esh/files/digest-esh-0.8-r2 b/app-shells/esh/files/digest-esh-0.8-r2
new file mode 100644
index 000000000000..4ea7be5f1d42
--- /dev/null
+++ b/app-shells/esh/files/digest-esh-0.8-r2
@@ -0,0 +1 @@
+MD5 b59022b88bae24420156d25869b8be54 esh-0.8.tar.gz