summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-11-22 19:19:35 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-11-22 19:19:35 +0000
commitca65aa4e093515af2cc532e9b8d4113c2408a10b (patch)
tree5fcd8562c87234ad7d03ab3c38a8cb3fcea3012b /app-shells
parentAdd metadata.xml (diff)
downloadgentoo-2-ca65aa4e093515af2cc532e9b8d4113c2408a10b.tar.gz
gentoo-2-ca65aa4e093515af2cc532e9b8d4113c2408a10b.tar.bz2
gentoo-2-ca65aa4e093515af2cc532e9b8d4113c2408a10b.zip
(#153687) Bump; make rsh optional, switch to sourceforge, use DESTDIR for installing (Allen S. Rout).
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdsh/ChangeLog8
-rw-r--r--app-shells/pdsh/files/digest-pdsh-2.113
-rw-r--r--app-shells/pdsh/pdsh-2.11.ebuild31
3 files changed, 41 insertions, 1 deletions
diff --git a/app-shells/pdsh/ChangeLog b/app-shells/pdsh/ChangeLog
index fe9fa0da4b89..6f6cf4b96b4d 100644
--- a/app-shells/pdsh/ChangeLog
+++ b/app-shells/pdsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/pdsh
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.1 2006/07/20 05:29:57 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.2 2006/11/22 19:19:35 dberkholz Exp $
+
+*pdsh-2.11 (22 Nov 2006)
+
+ 22 Nov 2006; Donnie Berkholz <dberkholz@gentoo.org>; +pdsh-2.11.ebuild:
+ (#153687) Bump; make rsh optional, switch to sourceforge, use DESTDIR for
+ installing (Allen S. Rout).
*pdsh-2.9 (20 Jul 2006)
diff --git a/app-shells/pdsh/files/digest-pdsh-2.11 b/app-shells/pdsh/files/digest-pdsh-2.11
new file mode 100644
index 000000000000..87453da76f3d
--- /dev/null
+++ b/app-shells/pdsh/files/digest-pdsh-2.11
@@ -0,0 +1,3 @@
+MD5 b67af953de2a86ad90b9a13e97fba89e pdsh-2.11.tar.gz 607236
+RMD160 8878f5b1cc47b975a4d48ca6ce708fc7be2f9a53 pdsh-2.11.tar.gz 607236
+SHA256 d84f3caa0fe7dcd82606506c0a9b9015b6009f7bf3f63aecf0fe02721644c0a9 pdsh-2.11.tar.gz 607236
diff --git a/app-shells/pdsh/pdsh-2.11.ebuild b/app-shells/pdsh/pdsh-2.11.ebuild
new file mode 100644
index 000000000000..cc4216e5c73e
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.11.ebuild,v 1.1 2006/11/22 19:19:35 dberkholz Exp $
+
+DESCRIPTION="A high-performance, parallel remote shell utility."
+HOMEPAGE="http://www.llnl.gov/linux/pdsh/pdsh.html"
+SRC_URI="mirror://sourceforge/pdsh/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="crypt readline rsh"
+RDEPEND="crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ --with-machines \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+