summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-01-24 10:18:17 +0000
committerFabian Groffen <grobian@gentoo.org>2010-01-24 10:18:17 +0000
commitc883bdd2064d768d0fa81faf7d6243042d1d6b3a (patch)
treeb797ca56a00459dc5a96a414142f8d578a51658a /app-shells
parentFixing DOCS so that it doesn't fail (diff)
downloadgentoo-2-c883bdd2064d768d0fa81faf7d6243042d1d6b3a.tar.gz
gentoo-2-c883bdd2064d768d0fa81faf7d6243042d1d6b3a.tar.bz2
gentoo-2-c883bdd2064d768d0fa81faf7d6243042d1d6b3a.zip
Install manpage in usr/share, bug #302028. Renamed USE=perl to USE=doc since that's what it does.
(Portage version: 2.2.00.15200-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/ChangeLog9
-rw-r--r--app-shells/tcsh/tcsh-6.17-r1.ebuild (renamed from app-shells/tcsh/tcsh-6.17.ebuild)13
2 files changed, 16 insertions, 6 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index e9c993200d45..db017a2fbe8a 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/tcsh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.96 2010/01/22 11:54:41 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.97 2010/01/24 10:18:17 grobian Exp $
+
+*tcsh-6.17-r1 (24 Jan 2010)
+
+ 24 Jan 2010; Fabian Groffen <grobian@gentoo.org> -tcsh-6.17.ebuild,
+ +tcsh-6.17-r1.ebuild:
+ Install manpage in usr/share, bug #302028. Renamed USE=perl to USE=doc
+ since that's what it does.
*tcsh-6.17 (22 Jan 2010)
diff --git a/app-shells/tcsh/tcsh-6.17.ebuild b/app-shells/tcsh/tcsh-6.17-r1.ebuild
index 82a6f6b71885..ebcade35a4fa 100644
--- a/app-shells/tcsh/tcsh-6.17.ebuild
+++ b/app-shells/tcsh/tcsh-6.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.17.ebuild,v 1.1 2010/01/22 11:54:41 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.17-r1.ebuild,v 1.1 2010/01/24 10:18:17 grobian Exp $
inherit eutils flag-o-matic autotools prefix
@@ -15,13 +15,13 @@ SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="perl catalogs"
+IUSE="catalogs doc"
RESTRICT="test"
# we need gettext because we run autoconf
DEPEND=">=sys-libs/ncurses-5.1
sys-devel/gettext
- perl? ( dev-lang/perl )"
+ doc? ( dev-lang/perl )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -67,14 +67,17 @@ src_compile() {
append-flags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
append-flags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
- econf --prefix="${EPREFIX:-/}" || die "econf failed"
+ econf \
+ --prefix="${EPREFIX:-/}" \
+ --datarootdir='${prefix}/usr/share' \
+ || die "econf failed"
emake || die "compile problem"
}
src_install() {
emake DESTDIR="${D}" install install.man || die
- if use perl ; then
+ if use doc ; then
perl tcsh.man2html tcsh.man || die
dohtml tcsh.html/*.html
fi