summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-02 12:41:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-02 12:41:59 +0000
commitb09d5420f90a8666bf37a526dc10a460bfc0ecd2 (patch)
treeba908e51d437e314d29b99a2cda6e3d15172a5fe /app-shells
parentVersion bump with minor bugfixes. Also adds passive BGP support. (diff)
downloadgentoo-2-b09d5420f90a8666bf37a526dc10a460bfc0ecd2.tar.gz
gentoo-2-b09d5420f90a8666bf37a526dc10a460bfc0ecd2.tar.bz2
gentoo-2-b09d5420f90a8666bf37a526dc10a460bfc0ecd2.zip
Initial commit wrt #45183, thanks to Ken Pizzini, Adrian Frühwirth and Arseny Solokha.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rc/ChangeLog10
-rw-r--r--app-shells/rc/metadata.xml9
-rw-r--r--app-shells/rc/rc-1.7.1.ebuild42
3 files changed, 61 insertions, 0 deletions
diff --git a/app-shells/rc/ChangeLog b/app-shells/rc/ChangeLog
new file mode 100644
index 000000000000..0ab3ec8c8ee1
--- /dev/null
+++ b/app-shells/rc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/rc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/ChangeLog,v 1.1 2009/10/02 12:41:59 ssuominen Exp $
+
+*rc-1.7.1 (02 Oct 2009)
+
+ 02 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> +rc-1.7.1.ebuild:
+ Initial commit wrt #45183, thanks to Ken Pizzini, Adrian Frühwirth and
+ Arseny Solokha.
+
diff --git a/app-shells/rc/metadata.xml b/app-shells/rc/metadata.xml
new file mode 100644
index 000000000000..eb72a8082544
--- /dev/null
+++ b/app-shells/rc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rc/rc-1.7.1.ebuild b/app-shells/rc/rc-1.7.1.ebuild
new file mode 100644
index 000000000000..fcf0ec2e6f9c
--- /dev/null
+++ b/app-shells/rc/rc-1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/rc-1.7.1.ebuild,v 1.1 2009/10/02 12:41:59 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://rc-shell.slackmatic.org/"
+SRC_URI="http://rc-shell.slackmatic.org/release/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-readline"
+ use libedit && myconf="--with-editline"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ into /
+ newbin rc rcsh || die
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/rcsh$" "${ROOT}"etc/shells; echo "/bin/rcsh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}