summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-09 09:06:26 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-09 09:06:26 +0000
commita63b983c6546507630ef1f3c4d55b0606efe5426 (patch)
treea0441731620b194115050e364d4877398a8c62bf /app-shells
parentEnhanced install phase to rm OSX forkfiles, fixes Bug #450842 by Flameeyes (diff)
downloadgentoo-2-a63b983c6546507630ef1f3c4d55b0606efe5426.tar.gz
gentoo-2-a63b983c6546507630ef1f3c4d55b0606efe5426.tar.bz2
gentoo-2-a63b983c6546507630ef1f3c4d55b0606efe5426.zip
Version bump
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/ChangeLog7
-rw-r--r--app-shells/autojump/autojump-21.3.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index fb28ccdc6b0d..eecf063cfb86 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.8 2013/01/09 08:55:21 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.9 2013/01/09 09:06:26 xmw Exp $
+
+*autojump-21.3.0 (09 Jan 2013)
+
+ 09 Jan 2013; Michael Weber <xmw@gentoo.org> +autojump-21.3.0.ebuild:
+ Version bump
*autojump-21.2.1 (09 Jan 2013)
diff --git a/app-shells/autojump/autojump-21.3.0.ebuild b/app-shells/autojump/autojump-21.3.0.ebuild
new file mode 100644
index 000000000000..ae0173170697
--- /dev/null
+++ b/app-shells/autojump/autojump-21.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.3.0.ebuild,v 1.1 2013/01/09 09:06:26 xmw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+DEPEND="test? ( dev-lang/python )"
+
+src_prepare() {
+ #https://github.com/joelthelion/autojump/issues/129
+ sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
+ -i tests/runtests.py || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ install_python() {
+ insinto "$(python_get_sitedir)"
+ doins tools/autojump_ipython.py
+ }
+ python_execute_function -q install_python
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}