summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-28 23:28:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-28 23:28:44 +0000
commit9b61041c6469eaa6884baa3e3aa5220988f43485 (patch)
tree18e020f8ab2fc9aa5174a2a97f6a0dd1283544ee /app-shells
parenttouchups (Manifest recommit) (diff)
downloadgentoo-2-9b61041c6469eaa6884baa3e3aa5220988f43485.tar.gz
gentoo-2-9b61041c6469eaa6884baa3e3aa5220988f43485.tar.bz2
gentoo-2-9b61041c6469eaa6884baa3e3aa5220988f43485.zip
we work with bash3 too #58708
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-20040704-r1.ebuild74
-rw-r--r--app-shells/bash-completion/files/bash-completion19
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-20040704-r12
4 files changed, 97 insertions, 6 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 2d5ebd04566e..297ba25a6397 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.67 2004/07/04 15:12:02 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.68 2004/07/28 23:28:44 vapier Exp $
+
+*bash-completion-20040704-r1 (28 Jul 2004)
+
+ 28 Jul 2004; Mike Frysinger <vapier@gentoo.org> files/bash-completion,
+ +bash-completion-20040704-r1.ebuild:
+ Add version detection for bash3 #58708 by blubbfisch.
*bash-completion-20040704 (04 Jul 2004)
diff --git a/app-shells/bash-completion/bash-completion-20040704-r1.ebuild b/app-shells/bash-completion/bash-completion-20040704-r1.ebuild
new file mode 100644
index 000000000000..4a4ec1e8e0d4
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20040704-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040704-r1.ebuild,v 1.1 2004/07/28 23:28:44 vapier Exp $
+
+GENCOMP_VERS="1.0_beta"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND=">=app-shells/bash-2.05a"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /usr/share/bash-completion
+ doins contrib/*
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion
+
+ dodoc Changelog README
+
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ insinto /etc/bash_completion.d
+ doins src/gentoo
+
+ docinto gentoo
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ if [ -f ${ROOT}/etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ fi
+
+ local bcfile moved
+ for bcfile in ${ROOT}/etc/bash_completion.d/{unrar,harbour,isql,larch,lilypond,p4,ri}
+ do
+
+ [ -f "${bcfile}" -a ! -L "${bcfile}" ] && moved="${bcfile##*/} ${moved}"
+ done
+
+ if [ -n "${moved}" ]
+ then
+ echo
+ ewarn "The contrib files: ${moved}"
+ ewarn "have been moved to /usr/share/bash-completion. Please DELETE"
+ ewarn "those old files in /etc/bash_completion.d and create symlinks."
+ fi
+ echo
+}
diff --git a/app-shells/bash-completion/files/bash-completion b/app-shells/bash-completion/files/bash-completion
index 27a250ca0728..048d91e1eb41 100644
--- a/app-shells/bash-completion/files/bash-completion
+++ b/app-shells/bash-completion/files/bash-completion
@@ -1,13 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.3 2004/07/14 21:37:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.4 2004/07/28 23:28:44 vapier Exp $
#
# START bash completion -- do not remove this line
bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
-if [ "$PS1" ] && [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] \
- && [ -f /etc/bash_completion ]; then # interactive shell
- # Source completion code
- . /etc/bash_completion
+dosource=0
+# interactive shell
+if [ "$PS1" ] && [ -f /etc/bash_completion ] ; then
+ if [ $bmajor -eq 2 ] && [ $bminor '>' 04 ] ; then
+ dosource=1
+ fi
+ if [ $bmajor -ge 3 ] ; then
+ dosource=1
+ fi
+fi
+if [ ${dosource} -eq 1 ] ; then
+ # Source completion code
+ . /etc/bash_completion
fi
unset bash bmajor bminor
# END bash completion -- do not remove this line
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20040704-r1 b/app-shells/bash-completion/files/digest-bash-completion-20040704-r1
new file mode 100644
index 000000000000..71d744fd8807
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20040704-r1
@@ -0,0 +1,2 @@
+MD5 1a0991f4ff892ed6fed1c6cf39ee7022 bash-completion-20040704.tar.bz2 82544
+MD5 8776015ce9bbf116e34a149ef0846c85 gentoo-bashcomp-1.0_beta.tar.gz 13346