summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-04-19 22:40:02 +0000
committerSteve Dibb <beandog@gentoo.org>2011-04-19 22:40:02 +0000
commit99c06b8e3113e01a6c12e5c3bc8f2b4ec58a1888 (patch)
treee57a1b7601f079a494b67c7d60a4281f566b17bc /app-shells
parentVersion bump thanks to euscan. Add USE=static-libs. (diff)
downloadgentoo-2-99c06b8e3113e01a6c12e5c3bc8f2b4ec58a1888.tar.gz
gentoo-2-99c06b8e3113e01a6c12e5c3bc8f2b4ec58a1888.tar.bz2
gentoo-2-99c06b8e3113e01a6c12e5c3bc8f2b4ec58a1888.zip
Version bump, bug 344339
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rssh/ChangeLog9
-rw-r--r--app-shells/rssh/rssh-2.3.3.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-shells/rssh/ChangeLog b/app-shells/rssh/ChangeLog
index d158b20e6b0e..154341f481fa 100644
--- a/app-shells/rssh/ChangeLog
+++ b/app-shells/rssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/rssh
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/rssh/ChangeLog,v 1.18 2008/02/20 12:55:46 caleb Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rssh/ChangeLog,v 1.19 2011/04/19 22:40:02 beandog Exp $
+
+*rssh-2.3.3 (19 Apr 2011)
+
+ 19 Apr 2011; Steve Dibb <beandog@gentoo.org> +rssh-2.3.3.ebuild:
+ Version bump, bug 344339
20 Feb 2008; Caleb Tennis <caleb@gentoo.org> ChangeLog:
remove old version
diff --git a/app-shells/rssh/rssh-2.3.3.ebuild b/app-shells/rssh/rssh-2.3.3.ebuild
new file mode 100644
index 000000000000..37ebe52b040b
--- /dev/null
+++ b/app-shells/rssh/rssh-2.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rssh/rssh-2.3.3.ebuild,v 1.1 2011/04/19 22:40:02 beandog Exp $
+
+inherit multilib
+
+DESCRIPTION="Restricted shell for SSHd"
+HOMEPAGE="http://rssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rssh/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static"
+
+RDEPEND="virtual/ssh"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:chmod u+s $(:chmod u+s $(DESTDIR)$(:' Makefile.in
+}
+
+src_compile() {
+ econf \
+ --libexecdir='$(libdir)/misc' \
+ --with-scp=/usr/bin/scp \
+ --with-sftp-server="/usr/$(get_libdir)/misc/sftp-server" \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog CHROOT INSTALL README TODO
+}