summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-10-12 00:00:49 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-10-12 00:00:49 +0000
commit7fe9ddcc5b2d0ff1b74c508848857575b495c569 (patch)
tree24f429b27faf54a72fbf86becd5cc1d0f017f76d /app-shells
parentStable on hppa. (diff)
downloadgentoo-2-7fe9ddcc5b2d0ff1b74c508848857575b495c569.tar.gz
gentoo-2-7fe9ddcc5b2d0ff1b74c508848857575b495c569.tar.bz2
gentoo-2-7fe9ddcc5b2d0ff1b74c508848857575b495c569.zip
Version bump; closes #67148.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/Manifest4
-rw-r--r--app-shells/bash-completion/bash-completion-20040711.ebuild74
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200407112
4 files changed, 86 insertions, 2 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index f883e38121e6..c230b5dbfec0 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.70 2004/10/11 23:32:12 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.71 2004/10/12 00:00:49 ka0ttic Exp $
+
+*bash-completion-20040711 (11 Oct 2004)
+
+ 11 Oct 2004; Aaron Walker <ka0ttic@gentoo.org>
+ +bash-completion-20040711.ebuild:
+ Version bump; closes #67148.
11 Oct 2004; Aaron Walker <ka0ttic@gentoo.org> metadata.xml:
Updated metadata to reflect new shell-tools herd.
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index b5240eaa806a..81b65ad49e12 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,10 +1,12 @@
+MD5 8b6c24950923c9632c8c7df482e6296d bash-completion-20040711.ebuild 2094
MD5 115faf601395c07a603403509d2e6e25 bash-completion-20040526.ebuild 1918
MD5 cc5ea05a3deb5a269cb42964b943b230 bash-completion-20040704.ebuild 2091
MD5 0c67559393ee08d7446bc1fbf4420985 bash-completion-20040704-r1.ebuild 2086
-MD5 510179c1d60a4b5f0e4039a8d01236eb ChangeLog 9979
+MD5 f28de3bcef3abf2f3297763e487b3e3d ChangeLog 10137
MD5 00e8cae3d9ece63e4be61f4a2b3afd5e metadata.xml 930
MD5 4bbcbd54e5ec94b050417205572e13e9 files/gentoo.completion-20040526 16023
MD5 ff208a2c09a302be5db88edf519a4086 files/bash-completion 626
MD5 1c828ed53387932b8ed971aafa179875 files/digest-bash-completion-20040526 76
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704 151
+MD5 73c3177da25971c1db7bb6482b5d1580 files/digest-bash-completion-20040711 151
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704-r1 151
diff --git a/app-shells/bash-completion/bash-completion-20040711.ebuild b/app-shells/bash-completion/bash-completion-20040711.ebuild
new file mode 100644
index 000000000000..ecfd2e8eca1b
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20040711.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040711.ebuild,v 1.1 2004/10/12 00:00:49 ka0ttic Exp $
+
+GENCOMP_VERS="1.0_beta"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND=">=app-shells/bash-2.05a"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /usr/share/bash-completion
+ doins contrib/*
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion
+
+ dodoc Changelog README
+
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ insinto /etc/bash_completion.d
+ doins src/gentoo
+
+ docinto gentoo
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ if [ -f ${ROOT}/etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ fi
+
+ local bcfile moved
+ for bcfile in ${ROOT}/etc/bash_completion.d/{unrar,harbour,isql,larch,lilypond,p4,ri}
+ do
+
+ [ -f "${bcfile}" -a ! -L "${bcfile}" ] && moved="${bcfile##*/} ${moved}"
+ done
+
+ if [ -n "${moved}" ]
+ then
+ echo
+ ewarn "The contrib files: ${moved}"
+ ewarn "have been moved to /usr/share/bash-completion. Please DELETE"
+ ewarn "those old files in /etc/bash_completion.d and create symlinks."
+ fi
+ echo
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20040711 b/app-shells/bash-completion/files/digest-bash-completion-20040711
new file mode 100644
index 000000000000..af1431da426a
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20040711
@@ -0,0 +1,2 @@
+MD5 985c0ff1f94fca97ad1cbf191bdf8535 bash-completion-20040711.tar.bz2 82790
+MD5 8776015ce9bbf116e34a149ef0846c85 gentoo-bashcomp-1.0_beta.tar.gz 13346