summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-22 05:03:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-22 05:03:18 +0000
commit61352d43868735d6b3a9cd86ecf70b4bf9121013 (patch)
tree7f023f35d75639472266a6fb1650bddad4689d99 /app-shells
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-61352d43868735d6b3a9cd86ecf70b4bf9121013.tar.gz
gentoo-2-61352d43868735d6b3a9cd86ecf70b4bf9121013.tar.bz2
gentoo-2-61352d43868735d6b3a9cd86ecf70b4bf9121013.zip
try to fix the static linking right #63594
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b-r10.ebuild14
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild14
-rw-r--r--app-shells/bash/bash-3.0-r5.ebuild16
3 files changed, 34 insertions, 10 deletions
diff --git a/app-shells/bash/bash-2.05b-r10.ebuild b/app-shells/bash/bash-2.05b-r10.ebuild
index 67305a6e40b8..560bc17f1580 100644
--- a/app-shells/bash/bash-2.05b-r10.ebuild
+++ b/app-shells/bash/bash-2.05b-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.5 2004/09/09 02:05:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.6 2004/09/22 05:03:18 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -62,6 +62,8 @@ src_unpack() {
echo '#define PGRP_PIPE 1' >> config-bot.h
gnuconfig_update
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
src_compile() {
@@ -82,13 +84,19 @@ src_compile() {
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf="${myconf} --disable-nls"
+ echo 'int main(){}' > ${T}/term-test.c
+ if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ export bash_cv_termcap_lib=gnutermcap
+ else
+ export bash_cv_termcap_lib=libcurses
+ fi
+
econf \
--disable-profiling \
- --with-curses \
--without-gnu-malloc \
${myconf} || die
# Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lcurses:-Wl,-Bstatic -lcurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake || die "make failed"
}
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
index 07848deefa1a..fcc9eef59f71 100644
--- a/app-shells/bash/bash-2.05b-r9.ebuild
+++ b/app-shells/bash/bash-2.05b-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.20 2004/09/09 02:05:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.21 2004/09/22 05:03:18 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -60,6 +60,8 @@ src_unpack() {
echo '#define PGRP_PIPE 1' >> config-bot.h
gnuconfig_update
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
src_compile() {
@@ -80,13 +82,19 @@ src_compile() {
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf="${myconf} --disable-nls"
+ echo 'int main(){}' > ${T}/term-test.c
+ if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ export bash_cv_termcap_lib=gnutermcap
+ else
+ export bash_cv_termcap_lib=libcurses
+ fi
+
econf \
--disable-profiling \
- --with-curses \
--without-gnu-malloc \
${myconf} || die
# Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lcurses:-Wl,-Bstatic -lcurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake || die "make failed"
}
diff --git a/app-shells/bash/bash-3.0-r5.ebuild b/app-shells/bash/bash-3.0-r5.ebuild
index 52051e3159e5..dbf3bbabd303 100644
--- a/app-shells/bash/bash-3.0-r5.ebuild
+++ b/app-shells/bash/bash-3.0-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r5.ebuild,v 1.4 2004/09/09 02:05:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r5.ebuild,v 1.5 2004/09/22 05:03:18 vapier Exp $
-inherit eutils flag-o-matic gnuconfig
+inherit eutils flag-o-matic gnuconfig gcc
# Official patches
PLEVEL=""
@@ -92,6 +92,8 @@ src_unpack() {
echo '#define PGRP_PIPE 1' >> config-bot.h
gnuconfig_update
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
src_compile() {
@@ -112,13 +114,19 @@ src_compile() {
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf="${myconf} --disable-nls"
+ echo 'int main(){}' > ${T}/term-test.c
+ if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ export bash_cv_termcap_lib=gnutermcap
+ else
+ export bash_cv_termcap_lib=libcurses
+ fi
+
econf \
--disable-profiling \
- --with-curses \
--without-gnu-malloc \
${myconf} || die
# Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lcurses:-Wl,-Bstatic -lcurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake || die "make failed"
}