summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-15 03:54:56 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-15 03:54:56 +0000
commit57431f6243acc0f812c2f1a87315bf08ccfc929e (patch)
tree081c694af48b11509fde4df127e95e27c4b2e834 /app-shells
parentFix ldap problem with -sasl, bug #381315 thank Martin Stockinger for report a... (diff)
downloadgentoo-2-57431f6243acc0f812c2f1a87315bf08ccfc929e.tar.gz
gentoo-2-57431f6243acc0f812c2f1a87315bf08ccfc929e.tar.bz2
gentoo-2-57431f6243acc0f812c2f1a87315bf08ccfc929e.zip
Version bump #381777 by Hans.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog7
-rw-r--r--app-shells/dash/dash-0.5.7.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 850a86eb3dd7..7559a95f7965 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.82 2011/06/08 15:40:36 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.83 2011/09/15 03:54:56 vapier Exp $
+
+*dash-0.5.7.1 (15 Sep 2011)
+
+ 15 Sep 2011; Mike Frysinger <vapier@gentoo.org> +dash-0.5.7.1.ebuild:
+ Version bump #381777 by Hans.
08 Jun 2011; Matt Turner <mattst88@gentoo.org> dash-0.5.5.1.7.ebuild:
Add ~mips keyword, prerequisite for bug 370685
diff --git a/app-shells/dash/dash-0.5.7.1.ebuild b/app-shells/dash/dash-0.5.7.1.ebuild
new file mode 100644
index 000000000000..bc71be40b4b9
--- /dev/null
+++ b/app-shells/dash/dash-0.5.7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.7.1.ebuild,v 1.1 2011/09/15 03:54:56 vapier Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libedit static"
+
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${DEB_PF}.diff
+ epatch */debian/diff/*
+ epatch "${FILESDIR}"/${PN}-0.5.5.1-octal.patch #337329
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Use pkg-config for libedit linkage
+ sed -i "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(use static && echo --static)\`:" configure.ac
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --bindir=/bin \
+ $(use_with libedit)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog */debian/changelog
+}