summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-10 12:00:37 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-10 12:00:37 +0000
commit56270889e7a440c4e501494a521d787bfe043a7d (patch)
tree2f5418a0236e148ff2891865508b27d327c4a9e5 /app-shells
parentUpdate to EAPI5, drop old. (diff)
downloadgentoo-2-56270889e7a440c4e501494a521d787bfe043a7d.tar.gz
gentoo-2-56270889e7a440c4e501494a521d787bfe043a7d.tar.bz2
gentoo-2-56270889e7a440c4e501494a521d787bfe043a7d.zip
Revision bump: EAPI 5, fix silent building and respect CFLAGS wrt bug #439974
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/shish/ChangeLog7
-rw-r--r--app-shells/shish/shish-0.7_pre3-r1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-shells/shish/ChangeLog b/app-shells/shish/ChangeLog
index e8b4fb97e0ae..2e4978f139ae 100644
--- a/app-shells/shish/ChangeLog
+++ b/app-shells/shish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/shish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/shish/ChangeLog,v 1.7 2012/12/10 07:40:59 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/shish/ChangeLog,v 1.8 2012/12/10 12:00:37 pinkbyte Exp $
+
+*shish-0.7_pre3-r1 (10 Dec 2012)
+
+ 10 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +shish-0.7_pre3-r1.ebuild:
+ Revision bump: EAPI 5, fix silent building and respect CFLAGS wrt bug #439974
10 Dec 2012; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
remove myself from metadata
diff --git a/app-shells/shish/shish-0.7_pre3-r1.ebuild b/app-shells/shish/shish-0.7_pre3-r1.ebuild
new file mode 100644
index 000000000000..8d18b8759480
--- /dev/null
+++ b/app-shells/shish/shish-0.7_pre3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/shish/shish-0.7_pre3-r1.ebuild,v 1.1 2012/12/10 12:00:37 pinkbyte Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="The diet shell"
+HOMEPAGE="http://www.blah.ch/shish/"
+SRC_URI="http://www.blah.ch/${PN}/pkg/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug diet"
+
+DEPEND="diet? ( dev-libs/dietlibc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+pkg_setup() {
+ use diet && export CC="diet $(tc-getCC) -nostdinc"
+}
+
+src_prepare() {
+ # Respect CFLAGS, bug #439974
+ sed -i \
+ -e '/CFLAGS="$CFLAGS/d' \
+ -e '/-fexpensive-optimizations -fomit-frame-pointer/d' \
+ configure || die 'sed on configure failed'
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-quiet # bug 439974
+}
+
+src_compile() {
+ # parallel make is b0rked
+ emake -j1
+}
+
+src_install() {
+ default
+ doman doc/man/shish.1
+}
+
+pkg_postinst() {
+ einfo "Updating ${ROOT}etc/shells"
+ ( grep -v "^/bin/shish$" "${ROOT}"etc/shells; echo "/bin/shish" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+}