summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-14 04:41:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-14 04:41:57 +0000
commit5176c4265afe1c8e2c22eb6303cb3eb33047ae6b (patch)
tree008fd8424339125998221735223b011b5a646e1e /app-shells
parentcommit work-around for (I think) broken sandbox behavior (diff)
downloadgentoo-2-5176c4265afe1c8e2c22eb6303cb3eb33047ae6b.tar.gz
gentoo-2-5176c4265afe1c8e2c22eb6303cb3eb33047ae6b.tar.bz2
gentoo-2-5176c4265afe1c8e2c22eb6303cb3eb33047ae6b.zip
Cleaned up ebuild slightly
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdksh/ChangeLog9
-rw-r--r--app-shells/pdksh/pdksh-5.2.14-r4.ebuild19
2 files changed, 18 insertions, 10 deletions
diff --git a/app-shells/pdksh/ChangeLog b/app-shells/pdksh/ChangeLog
index d9128f611e7e..4ee22d086c6b 100644
--- a/app-shells/pdksh/ChangeLog
+++ b/app-shells/pdksh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/pdksh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/ChangeLog,v 1.2 2002/04/14 04:22:17 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/ChangeLog,v 1.3 2002/04/14 04:41:57 seemant Exp $
+
+*pdksh-5.2.14-r4 (13 Apr 2002)
+
+ 13 Apr 2002; Seemant Kulleen <seemant@gentoo.org> pdksh-5.2.14-r4.ebuild :
+
+ Updated ebuild syntax from try to || die and removed the CHOST business from
+ ./configure
*pdksh-5.2.14-r4 (13 Apr 2002)
diff --git a/app-shells/pdksh/pdksh-5.2.14-r4.ebuild b/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
index fdb4c338d0ac..1f84674a918a 100644
--- a/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
+++ b/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r4.ebuild,v 1.1 2002/04/14 04:22:18 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r4.ebuild,v 1.2 2002/04/14 04:41:57 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The Public Domain Korn Shell"
@@ -18,22 +18,23 @@ src_unpack() {
}
src_compile() {
+
echo 'ksh_cv_dev_fd=${ksh_cv_dev_fd=yes}' > config.cache
- try ./configure --prefix=/usr --host=${CHOST}
- try make
+
+ ./configure \
+ --prefix=/usr \
+ || die
+
+ emake || die
}
src_install() {
+
dobin ksh
into usr
doman ksh.1
dodoc BUG-REPORTS ChangeLog* CONTRIBUTORS LEGAL NEWS NOTES PROJECTS README
docinto etc
dodoc etc/*
-}
-
-
-
-
-
+}