summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-30 05:11:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-30 05:11:37 +0000
commit39bdb9d0348a04ee682611e98fa9dc5d1f927d9c (patch)
treee3a2a9af7c61fbac6a6f56bd9977f0171fe81077 /app-shells
parentamd64 stable (diff)
downloadgentoo-2-39bdb9d0348a04ee682611e98fa9dc5d1f927d9c.tar.gz
gentoo-2-39bdb9d0348a04ee682611e98fa9dc5d1f927d9c.tar.bz2
gentoo-2-39bdb9d0348a04ee682611e98fa9dc5d1f927d9c.zip
Move /etc/bash/bashrc to /etc/bashrc and fix built-in read with -u pipes #87093 by Michael Haubenwallner.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog9
-rw-r--r--app-shells/bash/bash-3.0-r9.ebuild146
-rw-r--r--app-shells/bash/files/bash-3.0-read-builtin-pipe.patch20
-rw-r--r--app-shells/bash/files/digest-bash-3.0-r918
4 files changed, 192 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 5a40cd1e6721..588416d498bd 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.58 2005/02/10 02:53:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.59 2005/03/30 05:11:37 vapier Exp $
+
+*bash-3.0-r9 (30 Mar 2005)
+
+ 30 Mar 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.0-read-builtin-pipe.patch, +bash-3.0-r9.ebuild:
+ Move /etc/bash/bashrc to /etc/bashrc and fix built-in read with -u pipes
+ #87093 by Michael Haubenwallner.
*bash-3.0-r8 (09 Feb 2005)
diff --git a/app-shells/bash/bash-3.0-r9.ebuild b/app-shells/bash/bash-3.0-r9.ebuild
new file mode 100644
index 000000000000..a735676772b9
--- /dev/null
+++ b/app-shells/bash/bash-3.0-r9.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r9.ebuild,v 1.1 2005/03/30 05:11:37 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.0-patches/
+PLEVEL=16
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+# Hit the GNU mirrors before hitting Chet's site
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls build"
+
+# we link statically with ncurses
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${P}-gentoo.diff.bz2
+
+ # Remove autoconf dependency
+ sed -i -e "/&& autoconf/d" Makefile.in
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
+ done
+
+ # Patch readline's bind.c so that /etc/inputrc is read as a last resort
+ # following ~/.inputrc. This is better than putting INPUTRC in
+ # the environment because INPUTRC will override even after the
+ # user creates a ~/.inputrc
+ epatch "${FILESDIR}"/${P}-etc-inputrc.patch
+
+ # Fix using bash with post-20040808 glibc ebuilds (from fedora)
+ epatch "${FILESDIR}"/${P}-jobs.patch
+
+ # Fix read-builtin and the -u pipe option #87093
+ epatch "${FILESDIR}"/${P}-read-builtin-pipe.patch
+
+ # Enable SSH_SOURCE_BASHRC (#24762)
+ echo '#define SSH_SOURCE_BASHRC' >> config-top.h
+
+ # Enable system-wide bashrc (#26952)
+ echo '#define SYS_BASHRC "/etc/bashrc"' >> config-top.h
+
+ # Force pgrp synchronization
+ # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
+ #
+ # The session will hang cases where you 'su' (not 'su -') and
+ # then run a piped command in emacs.
+ # This problem seem to happen due to scheduler changes kernel
+ # side - although reproduceble with later 2.4 kernels, it is
+ # especially easy with 2.6 kernels.
+ echo '#define PGRP_PIPE 1' >> config-bot.h
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ echo 'int main(){}' > "${T}"/term-test.c
+ if ! $(tc-getCC) -static -lncurses "${T}"/term-test.c 2> /dev/null ; then
+ export bash_cv_termcap_lib=gnutermcap
+ else
+ export bash_cv_termcap_lib=libcurses
+ myconf="${myconf} --with-ncurses"
+ fi
+
+ econf \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ # Make sure we always link statically with ncurses
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-L${ROOT}/usr/lib -Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/
+ dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ insinto /etc
+ doins "${FILESDIR}"/bashrc
+
+ if use build ; then
+ rm -rf "${D}"/usr
+ else
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] ; then
+ export BASHRC_MOVE=no
+ else
+ export BASHRC_MOVE=yes
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${BASHRC_MOVE} == "yes" ]] && [[ -e ${ROOT}/etc/bash/bashrc ]] ; then
+ mv "${ROOT}"/etc/bash/bashrc "${ROOT}"/etc/bashrc
+ rmdir "${ROOT}"/etc/bash >& /dev/null
+ fi
+}
diff --git a/app-shells/bash/files/bash-3.0-read-builtin-pipe.patch b/app-shells/bash/files/bash-3.0-read-builtin-pipe.patch
new file mode 100644
index 000000000000..466e45ae3004
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-read-builtin-pipe.patch
@@ -0,0 +1,20 @@
+Description:
+When using 'read -u 3' or the like, and the pipe-buf already contains
+more than one line, the first line is returned, and bytes up to the next
+multiple of 128 are skipped.
+
+http://lists.gnu.org/archive/html/bug-bash/2005-03/msg00168.html
+http://lists.gnu.org/archive/html/bug-bash/2005-03/msg00173.html
+http://bugs.gentoo.org/show_bug.cgi?id=87093
+
+--- builtins/read.def
++++ builtins/read.def
+@@ -276,7 +276,7 @@
+ input_is_tty = isatty (fd);
+ if (input_is_tty == 0)
+ #ifndef __CYGWIN__
+- input_is_pipe = (lseek (0, 0L, SEEK_CUR) < 0) && (errno == ESPIPE);
++ input_is_pipe = (lseek (fd, 0L, SEEK_CUR) < 0) && (errno == ESPIPE);
+ #else
+ input_is_pipe = 1;
+ #endif
diff --git a/app-shells/bash/files/digest-bash-3.0-r9 b/app-shells/bash/files/digest-bash-3.0-r9
new file mode 100644
index 000000000000..3f6ecc696328
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.0-r9
@@ -0,0 +1,18 @@
+MD5 26c4d642e29b3533d8d754995bc277b3 bash-3.0.tar.gz 2418293
+MD5 220cdd45dc060fd41c2bd7c46e8a9064 bash-3.0-gentoo.diff.bz2 2423
+MD5 24a83f78a44a6029024371f02da174dd bash30-001 4999
+MD5 6f4cf2aa975a1fcc0cb43a406bd47ca5 bash30-002 2119
+MD5 c8bf41e78cda16d391b9099eeba01386 bash30-003 4669
+MD5 c069dffbb3f442aac3660b883ddd97f5 bash30-004 3372
+MD5 ad06309c623ff8e1b9f039d3b7eb97c2 bash30-005 1776
+MD5 f162bf93a76759bab37b29509a4a6e20 bash30-006 4258
+MD5 89903d92ca620921aecb3f1f30c05ebe bash30-007 1808
+MD5 9a295c02f46bc867fc096862c7380a88 bash30-008 1220
+MD5 786c7e2af1dca5104af92bbdc60f7474 bash30-009 2828
+MD5 f2d90d06ed445a285c8406016e9d9c13 bash30-010 3193
+MD5 9506c56968c58332489986633319a186 bash30-011 2635
+MD5 2753d4de0b57fc8890488463c5e86d3f bash30-012 1395
+MD5 5de5be8289764c11a3206b06351d81a6 bash30-013 1963
+MD5 d4b531e02b6a0287cffdbf527134ca29 bash30-014 1165
+MD5 adc1ab952b42ed0c0f53d1c308a32101 bash30-015 1480
+MD5 a3bb09a185e4c6a813227f3e84e4f6e5 bash30-016 2453