summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-12 23:44:04 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-12 23:44:04 +0000
commit2e676309bdfc3d09e108cc621831bc520a9ad310 (patch)
tree2eafbe90e5c244da5120db8b279b160906665999 /app-shells
parentTricksy patchesess, mispellses thems we does. (Manifest recommit) (diff)
downloadgentoo-2-2e676309bdfc3d09e108cc621831bc520a9ad310.tar.gz
gentoo-2-2e676309bdfc3d09e108cc621831bc520a9ad310.tar.bz2
gentoo-2-2e676309bdfc3d09e108cc621831bc520a9ad310.zip
Clean up profile.d file thanks to Joker.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog5
-rw-r--r--app-shells/bash-completion/Manifest14
-rw-r--r--app-shells/bash-completion/files/bash-completion19
3 files changed, 14 insertions, 24 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 92662f99654c..e3079cd242ed 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.79 2004/11/12 10:57:56 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.80 2004/11/12 23:44:04 ka0ttic Exp $
+
+ 12 Nov 2004; Aaron Walker <ka0ttic@gentoo.org> files/bash-completion:
+ Clean up profile.d file thanks to Joker.
*bash-completion-20041017-r1 (12 Nov 2004)
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index c0b1f3573688..3eb9d60ab5bc 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,23 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 380396b5af573a9eb310e1f150288411 bash-completion-20041017-r1.ebuild 2238
MD5 50f43407f43fdbbfa26b4d63f947497a bash-completion-20040711.ebuild 2088
MD5 f6bee54f0c35dc47430924ecb49c03fb bash-completion-20040704.ebuild 2092
MD5 7d4aeaf81dd9f767c41a81c3e47d01a2 bash-completion-20040704-r1.ebuild 2087
-MD5 b197ca2dd572ccda2723645ee4763492 ChangeLog 11385
+MD5 58c17f202f6960a6d7860ba26f7d651b ChangeLog 11501
MD5 00e8cae3d9ece63e4be61f4a2b3afd5e metadata.xml 930
MD5 3790b4d8b911d7cb16effa66acdc6e93 bash-completion-20041017.ebuild 2123
MD5 236fd9c517ac5642cae8df109dbaf9f6 files/digest-bash-completion-20041017-r1 152
-MD5 5592b40975f8bc675c05dec7e52ca6ff files/bash-completion 790
+MD5 34c8acff860f67ce2398930336b13ad0 files/bash-completion 724
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704 151
MD5 73c3177da25971c1db7bb6482b5d1580 files/digest-bash-completion-20040711 151
MD5 236fd9c517ac5642cae8df109dbaf9f6 files/digest-bash-completion-20041017 152
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704-r1 151
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBlJdBEZCkKN40op4RAvfYAJ0cN18Ea8tGL/prNn9G5RbntKAHgACfeT3P
-WYIlod1pLbEgld0xAkj8D+s=
-=knWG
------END PGP SIGNATURE-----
diff --git a/app-shells/bash-completion/files/bash-completion b/app-shells/bash-completion/files/bash-completion
index 3d4699395054..e1e58e1e7a2c 100644
--- a/app-shells/bash-completion/files/bash-completion
+++ b/app-shells/bash-completion/files/bash-completion
@@ -1,22 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.6 2004/11/09 12:30:13 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.7 2004/11/12 23:44:04 ka0ttic Exp $
#
# START bash completion -- do not remove this line
bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
# interactive shell
-if [ "$PS1" ] && [ -f /etc/bash_completion ] ; then
+if [ "$PS1" ]; then
if [ $bmajor -eq 2 -a $bminor '>' 04 ] || [ $bmajor -ge 3 ]; then
- # Source completion code
- . /etc/bash_completion
+ [ -f /etc/bash_completion ] && . /etc/bash_completion
+ if [ -d ~/.bash_completion.d ] ; then
+ for file in ~/.bash_completion.d/* ; do
+ [ -f $file ] && . $file
+ done
+ fi
fi
fi
unset bash bmajor bminor
-
-# per-user completions
-if [ "$PS1" ] && [ -d ~/.bash_completion.d ] ; then
- for file in ~/.bash_completion.d/* ; do
- [ -f $file ] && source $file
- done
-fi
# END bash completion -- do not remove this line