summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 06:14:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 06:14:45 +0000
commit27f27f960604e843941b276880d3dd2a08acdb55 (patch)
treed29627a15180f92ff0dbd96b34886239191baf0e /app-shells
parentbase-system owns this (diff)
downloadgentoo-2-27f27f960604e843941b276880d3dd2a08acdb55.tar.gz
gentoo-2-27f27f960604e843941b276880d3dd2a08acdb55.tar.bz2
gentoo-2-27f27f960604e843941b276880d3dd2a08acdb55.zip
Version bump to force linking with newer zlib #100683.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/ChangeLog9
-rw-r--r--app-shells/sash/files/digest-sash-3.7-r11
-rw-r--r--app-shells/sash/sash-3.7-r1.ebuild46
3 files changed, 54 insertions, 2 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index 3c6586ec945d..99fb372ded25 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/sash
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.35 2005/05/31 15:23:41 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.36 2005/07/30 06:14:45 vapier Exp $
+
+*sash-3.7-r1 (30 Jul 2005)
+
+ 30 Jul 2005; Mike Frysinger <vapier@gentoo.org> +sash-3.7-r1.ebuild:
+ Version bump to force linking with newer zlib #100683.
31 May 2005; Sven Wegener <swegener@gentoo.org> sash-3.7.ebuild:
Let portage handle the stripping of binaries.
diff --git a/app-shells/sash/files/digest-sash-3.7-r1 b/app-shells/sash/files/digest-sash-3.7-r1
new file mode 100644
index 000000000000..927cceb6610b
--- /dev/null
+++ b/app-shells/sash/files/digest-sash-3.7-r1
@@ -0,0 +1 @@
+MD5 ee7c7ed5aad76599974d016a6f201ef4 sash-3.7.tar.gz 50337
diff --git a/app-shells/sash/sash-3.7-r1.ebuild b/app-shells/sash/sash-3.7-r1.ebuild
new file mode 100644
index 000000000000..4c25a40e37b6
--- /dev/null
+++ b/app-shells/sash/sash-3.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7-r1.ebuild,v 1.1 2005/07/30 06:14:45 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A small static UNIX Shell with readline support"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="readline"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ readline? (
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/sash-3.6-fix-includes.patch
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+ use readline && epatch "${FILESDIR}"/sash-3.6-readline.patch
+
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/^LDFLAGS /s: -s$: ${LDFLAGS}:" \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ into /
+ dobin sash || die
+ doman sash.1
+ dodoc README
+}