summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-09 01:07:59 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-09 01:07:59 +0000
commit17c9a27ba1b4e7788225890f07dec3a7c12de301 (patch)
treeff7863ccfb1a76d9e00e576c835f086225cee002 /app-shells
parent Fix bug #229093 and #226421. Get rid of the invalid aRts dependency. (diff)
downloadgentoo-2-17c9a27ba1b4e7788225890f07dec3a7c12de301.tar.gz
gentoo-2-17c9a27ba1b4e7788225890f07dec3a7c12de301.tar.bz2
gentoo-2-17c9a27ba1b4e7788225890f07dec3a7c12de301.zip
Add fix from upstream #231775 by Joe Peterson and allow people to turn off net redirection #242412 by Chris Frederick.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog10
-rw-r--r--app-shells/bash/bash-3.2_p48-r1.ebuild204
-rw-r--r--app-shells/bash/files/bash-3.2-protos.patch45
-rw-r--r--app-shells/bash/files/bash-3.2-session-leader.patch65
-rw-r--r--app-shells/bash/metadata.xml1
5 files changed, 324 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index a4e05e66d35d..55766817cac3 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.193 2009/02/05 19:06:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.194 2009/02/09 01:07:59 vapier Exp $
+
+*bash-3.2_p48-r1 (09 Feb 2009)
+
+ 09 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.2-protos.patch, +files/bash-3.2-session-leader.patch,
+ metadata.xml, +bash-3.2_p48-r1.ebuild:
+ Add fix from upstream #231775 by Joe Peterson and allow people to turn off
+ net redirection #242412 by Chris Frederick.
05 Feb 2009; Raúl Porcel <armin76@gentoo.org> bash-3.2_p39.ebuild:
arm/ia64/s390/sh stable wrt #235020
diff --git a/app-shells/bash/bash-3.2_p48-r1.ebuild b/app-shells/bash/bash-3.2_p48-r1.ebuild
new file mode 100644
index 000000000000..81feb4c1dcec
--- /dev/null
+++ b/app-shells/bash/bash-3.2_p48-r1.ebuild
@@ -0,0 +1,204 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p48-r1.ebuild,v 1.1 2009/02/09 01:07:59 vapier Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.2-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+READLINE_VER=5.2
+READLINE_PLEVEL=0 # both readline patches are also released as bash patches
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)
+ $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="afs bashlogger examples +net nls plugins vanilla"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="${DEPEND}
+ !<sys-apps/portage-2.1.5
+ !<sys-apps/paludis-0.26.0_alpha5"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if is-flag -malign-double ; then #7332
+ eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
+ eerror "as it breaks LFS (struct stat64) on x86."
+ die "remove -malign-double from your CFLAGS mr ricer"
+ fi
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ cd lib/readline
+ for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
+ done
+ cd ../..
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/autoconf-mktime-2.59.patch #220040
+ epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-3.2-loadables.patch
+ epatch "${FILESDIR}"/${PN}-3.2-protos.patch
+ epatch "${FILESDIR}"/${PN}-3.2-session-leader.patch #231775
+ epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
+ epatch "${FILESDIR}"/${PN}-3.2-ldflags-for-build.patch #211947
+
+ # Fix process substitution on BSD.
+ epatch "${FILESDIR}"/${PN}-3.2-process-subst.patch
+
+ epatch "${FILESDIR}"/${PN}-3.2-ulimit.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+ epatch "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch #131875
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
+ fi
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.0-configs.patch
+}
+
+src_compile() {
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #myconf="${myconf} $(use_with !readline installed-readline)"
+ myconf="${myconf} --without-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ myconf="${myconf} --with-curses"
+
+ # Default path is to use /usr/local/..... regardless. This little
+ # magic will set the default path to /usr/..... and keep us from
+ # worrying about the rest of the path getting out of sync with the
+ # ebuild code.
+ eval $(echo export $(ac_default_prefix=/usr; eval echo $(grep DEBUGGER_START_FILE= configure)))
+
+ use plugins && append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
+ econf \
+ $(use_with afs) \
+ $(use_with net net-redirections) \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake || die "make failed"
+
+ if use plugins ; then
+ emake -C examples/loadables all others || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/ || die
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+
+ if use plugins ; then
+ exeinto /usr/$(get_libdir)/bash
+ doexe $(echo examples/loadables/*.o | sed 's:\.o::g') || die
+ fi
+
+ if use examples ; then
+ for d in examples/{functions,misc,scripts,scripts.noah,scripts.v2} ; do
+ exeinto /usr/share/doc/${PF}/${d}
+ insinto /usr/share/doc/${PF}/${d}
+ for f in ${d}/* ; do
+ if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
+ doexe ${f}
+ else
+ doins ${f}
+ fi
+ done
+ done
+ fi
+
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info /usr/share/info/bashref.info
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+
+ if [[ -L ${ROOT}/bin/sh ]]; then
+ # rewrite the symlink to ensure that its mtime changes. having /bin/sh
+ # missing even temporarily causes a fatal error with paludis.
+ local target=$(readlink "${ROOT}"/bin/sh)
+ ln -sf "${target}" "${ROOT}"/bin/sh
+ fi
+}
+
+pkg_postinst() {
+ # If /bin/sh does not exist, provide it
+ if [[ ! -e ${ROOT}/bin/sh ]]; then
+ ln -sf bash "${ROOT}"/bin/sh
+ fi
+}
diff --git a/app-shells/bash/files/bash-3.2-protos.patch b/app-shells/bash/files/bash-3.2-protos.patch
new file mode 100644
index 000000000000..c6a997422b43
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-protos.patch
@@ -0,0 +1,45 @@
+move prototypes around so they show up when needed
+
+--- a/jobs.h
++++ b/jobs.h
+@@ -182,6 +182,7 @@
+
+ extern int count_all_jobs __P((void));
+
++extern void close_pgrp_pipe __P((void));
+ extern void terminate_current_pipeline __P((void));
+ extern void terminate_stopped_jobs __P((void));
+ extern void hangup_all_jobs __P((void));
+--- a/lib/glob/strmatch.c
++++ b/lib/glob/strmatch.c
+@@ -25,9 +25,6 @@
+ #include "strmatch.h"
+
+ extern int xstrmatch __P((char *, char *, int));
+-#if defined (HAVE_MULTIBYTE)
+-extern int internal_wstrmatch __P((wchar_t *, wchar_t *, int));
+-#endif
+
+ int
+ strmatch (pattern, string, flags)
+--- a/lib/glob/strmatch.h
++++ b/lib/glob/strmatch.h
+@@ -57,6 +57,7 @@
+
+ #if HANDLE_MULTIBYTE
+ extern int wcsmatch __P((wchar_t *, wchar_t *, int));
++extern int internal_wstrmatch __P((wchar_t *, wchar_t *, int));
+ #endif
+
+ #endif /* _STRMATCH_H */
+--- a/quit.h
++++ b/quit.h
+@@ -21,6 +21,8 @@
+ #if !defined (_QUIT_H_)
+ #define _QUIT_H_
+
++#include "sig.h"
++
+ /* Non-zero means SIGINT has already ocurred. */
+ extern volatile int interrupt_state;
+ extern volatile int terminating_signal;
diff --git a/app-shells/bash/files/bash-3.2-session-leader.patch b/app-shells/bash/files/bash-3.2-session-leader.patch
new file mode 100644
index 000000000000..82f7d9806333
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-session-leader.patch
@@ -0,0 +1,65 @@
+http://bugs.gentoo.org/231775
+http://lists.gnu.org/archive/html/bug-bash/2008-07/msg00010.html
+
+A parent bash shell sometimes will set the session leader tty (using tcsetpgrp)
+back to itself, taking control away from a child bash shell, due to a race
+condition. A result is that the child can then not then execute some commands
+(like stty) from its init script (e.g. .bashrc). The result I (and others)
+have seen is that the bash shell will hang while reading the init script.
+
+*** jobs.c.20080704 2008-07-10 15:14:13.000000000 -0400
+--- jobs.c 2008-07-10 15:17:59.000000000 -0400
+***************
+*** 266,269 ****
+--- 266,270 ----
+ static void set_job_running __P((int));
+ static void setjstatus __P((int));
++ static int maybe_give_terminal_to __P((pid_t, pid_t, int));
+ static void mark_all_jobs_as_dead __P((void));
+ static void mark_dead_jobs_as_notified __P((int));
+***************
+*** 637,641 ****
+ */
+ if (job_control && newjob->pgrp && (subshell_environment&SUBSHELL_ASYNC) == 0)
+! give_terminal_to (newjob->pgrp, 0);
+ }
+ }
+--- 638,642 ----
+ */
+ if (job_control && newjob->pgrp && (subshell_environment&SUBSHELL_ASYNC) == 0)
+! maybe_give_terminal_to (shell_pgrp, newjob->pgrp, 0);
+ }
+ }
+***************
+*** 3833,3836 ****
+--- 3834,3863 ----
+ }
+
++ /* Give terminal to NPGRP iff it's currently owned by OPGRP. FLAGS are the
++ flags to pass to give_terminal_to(). */
++ static int
++ maybe_give_terminal_to (opgrp, npgrp, flags)
++ pid_t opgrp, npgrp;
++ int flags;
++ {
++ int tpgrp;
++
++ tpgrp = tcgetpgrp (shell_tty);
++ if (tpgrp == npgrp)
++ {
++ terminal_pgrp = npgrp;
++ return 0;
++ }
++ else if (tpgrp != opgrp)
++ {
++ #if defined (DEBUG)
++ internal_warning ("maybe_give_terminal_to: terminal pgrp == %d shell pgrp = %d", tpgrp, opgrp);
++ #endif
++ return -1;
++ }
++ else
++ return (give_terminal_to (npgrp, flags));
++ }
++
+ /* Clear out any jobs in the job array. This is intended to be used by
+ children of the shell, who should not have any job structures as baggage
diff --git a/app-shells/bash/metadata.xml b/app-shells/bash/metadata.xml
index 224ab67daa20..67c5507b189d 100644
--- a/app-shells/bash/metadata.xml
+++ b/app-shells/bash/metadata.xml
@@ -5,6 +5,7 @@
<use>
<flag name='bashlogger'>Log ALL commands typed into bash; should ONLY be
used in restricted environments such as honeypots</flag>
+ <flag name='net'>Enable /dev/tcp/host/port redirection</flag>
<flag name='plugins'>Add support for loading builtins at runtime via
'enable'</flag>
</use>