summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2007-04-30 16:26:06 +0000
committerMamoru Komachi <usata@gentoo.org>2007-04-30 16:26:06 +0000
commit17173249bc74d71bae7991ea7fb3bc389f48563f (patch)
treeda1df4a4f5f3548a7f7132278d6adc6602b65aef /app-shells
parentAdded local use flag float for sci-libs/fftw-2 (diff)
downloadgentoo-2-17173249bc74d71bae7991ea7fb3bc389f48563f.tar.gz
gentoo-2-17173249bc74d71bae7991ea7fb3bc389f48563f.tar.bz2
gentoo-2-17173249bc74d71bae7991ea7fb3bc389f48563f.zip
Version bumped. (bug #175302) Changed zprofile to source /etc/profile.d/*.sh. (bug #19924) Set EDITOR variable. (bug #165000)
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog10
-rw-r--r--app-shells/zsh/files/digest-zsh-4.3.49
-rw-r--r--app-shells/zsh/files/zprofile35
-rw-r--r--app-shells/zsh/zsh-4.3.4.ebuild165
4 files changed, 213 insertions, 6 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 430729ec3db4..fb9622522944 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.108 2007/03/01 00:54:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.109 2007/04/30 16:26:06 usata Exp $
+
+*zsh-4.3.4 (30 Apr 2007)
+
+ 30 Apr 2007; Mamoru KOMACHI <usata@gentoo.org> files/zprofile,
+ +zsh-4.3.4.ebuild:
+ Version bumped. (bug #175302)
+ Changed zprofile to source /etc/profile.d/*.sh. (bug #19924)
+ Set $EDITOR variable. (bug #165000)
01 Mar 2007; Jason Wever <weeve@gentoo.org> zsh-4.3.2-r2.ebuild:
Stable on SPARC wrt bug #168320.
diff --git a/app-shells/zsh/files/digest-zsh-4.3.4 b/app-shells/zsh/files/digest-zsh-4.3.4
new file mode 100644
index 000000000000..535aa4ba10dc
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.3.4
@@ -0,0 +1,9 @@
+MD5 1a4ab09a9d75c5ae8585ad645406f27d zsh-4.3.4-doc.tar.bz2 2358063
+RMD160 768ce8ca2860139428d27a0fedf5c0724967e444 zsh-4.3.4-doc.tar.bz2 2358063
+SHA256 e74289f99479328b8bcee9c47ae07038e54437e860fb5487da57cfc8d1836777 zsh-4.3.4-doc.tar.bz2 2358063
+MD5 8410a30e4f5c6160790bc3afc096424f zsh-4.3.4.tar.bz2 2374851
+RMD160 2fe0fcf6371d2072c3b7eeae0392c7ef3665457c zsh-4.3.4.tar.bz2 2374851
+SHA256 6fa0e22cb0da3a02c115425097002f2b4bb56e412db6c821ca111e088cbfdec6 zsh-4.3.4.tar.bz2 2374851
+MD5 6ac4b81c087db2197cdcd8ff02e51619 zsh-lovers_0.5.orig.tar.gz 499014
+RMD160 505261d9e28554c838864421ec81b6665e55dfa1 zsh-lovers_0.5.orig.tar.gz 499014
+SHA256 d945adab65fdf3ff322ed64c54739b2a1cec964544c5f438005ddad9c0c62bea zsh-lovers_0.5.orig.tar.gz 499014
diff --git a/app-shells/zsh/files/zprofile b/app-shells/zsh/files/zprofile
index 089ab20f7e4f..69cae0b39ff0 100644
--- a/app-shells/zsh/files/zprofile
+++ b/app-shells/zsh/files/zprofile
@@ -1,14 +1,39 @@
# /etc/zsh/zprofile
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile,v 1.2 2006/11/02 19:49:32 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile,v 1.3 2007/04/30 16:26:06 usata Exp $
-[[ -e "/etc/profile.env" ]] && source /etc/profile.env
+# Load environment settings from profile.env, which is created by
+# env-update from the files in /etc/env.d
+if [ -e /etc/profile.env ] ; then
+ . /etc/profile.env
+fi
#077 would be more secure, but 022 is generally quite realistic
umask 022
-if [[ "$USER" == root ]]; then
- export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:${ROOTPATH}"
+# Set up PATH depending on whether we're root or a normal user.
+# There's no real reason to exclude sbin paths from the normal user,
+# but it can make tab-completion easier when they aren't in the
+# user's PATH to pollute the executable namespace.
+#
+# It is intentional in the following line to use || instead of -o.
+# This way the evaluation can be short-circuited and calling whoami is
+# avoided.
+if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
+ PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:${ROOTPATH}"
else
- export PATH="/usr/local/bin:/usr/bin:/bin:${PATH}"
+ PATH="/usr/local/bin:/usr/bin:/bin:${PATH}"
fi
+export PATH
unset ROOTPATH
+
+# Extract the value of EDITOR
+[ -z "$EDITOR" ] && EDITOR="`. /etc/rc.conf 2>/dev/null; echo $EDITOR`"
+[ -z "$EDITOR" ] && EDITOR="/bin/nano"
+export EDITOR
+
+for sh in /etc/profile.d/*.sh ; do
+ if [ -r "$sh" ] ; then
+ . "$sh"
+ fi
+done
+unset sh
diff --git a/app-shells/zsh/zsh-4.3.4.ebuild b/app-shells/zsh/zsh-4.3.4.ebuild
new file mode 100644
index 000000000000..8f9385f43e07
--- /dev/null
+++ b/app-shells/zsh/zsh-4.3.4.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.4.ebuild,v 1.1 2007/04/30 16:26:06 usata Exp $
+
+inherit eutils multilib
+
+LOVERS_PV=0.5
+LOVERS_P=zsh-lovers-${LOVERS_PV}
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
+ examples? (
+ http://www.grml.org/repos/zsh-lovers_${LOVERS_PV}.orig.tar.gz )
+ doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="maildir ncurses static doc examples pcre caps unicode"
+
+RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
+ caps? ( sys-libs/libcap )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-init.d-gentoo.diff
+ cd ${S}/Doc
+ ln -sf . man1
+ # fix zshall problem with soelim
+ soelim zshall.1 > zshall.1.soelim
+ mv zshall.1.soelim zshall.1
+}
+
+src_compile() {
+ local myconf
+
+ use static && myconf="${myconf} --disable-dynamic" \
+ && LDFLAGS="${LDFLAGS} -static"
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/$(get_libdir) \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ --with-tcsetpgrp \
+ $(use_with ncurses curses-terminfo) \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps) \
+ $(use_enable unicode multibyte) \
+ ${myconf} || die "configure failed"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ sed -i -e "s/link=no/link=static/g" \
+ -e "s/load=no/load=yes/g" \
+ config.modules || die
+ else
+ # avoid linking to libs in /usr/lib, see Bug #27064
+ sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
+ Makefile || die
+ fi
+
+ # emake still b0rks
+ emake -j1 || die "make failed"
+}
+
+src_test() {
+ for f in /dev/pt* ; do
+ addpredict $f
+ done
+ make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/$(get_libdir) \
+ fndir=${D}/usr/share/zsh/${PV%_*}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ scriptdir=${D}/usr/share/zsh/${PV%_*}/scripts \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ insinto /etc/zsh
+ doins ${FILESDIR}/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ doins ${FILESDIR}/prompt_gentoo_setup || die
+
+ # install miscellaneous scripts; bug #54520
+ sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
+ insinto /usr/share/zsh/${PV%_*}/Util
+ doins Util/* || die "doins Util scripts failed"
+ insinto /usr/share/zsh/${PV%_*}/Misc
+ doins Misc/* || die "doins Misc scripts failed"
+
+ dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
+
+ if use doc ; then
+ dohtml Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ fi
+
+ if use examples; then
+ cd ${WORKDIR}/${LOVERS_P}
+ doman zsh-lovers.1 || die "doman zsh-lovers failed"
+ dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
+ docinto zsh-lovers
+ dodoc zsh.vim README
+ insinto /usr/share/doc/${PF}/zsh-lovers
+ doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf}
+ doins -r zsh_people || die "doins zsh_people failed"
+ cd -
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_preinst() {
+ # Our zprofile file does the job of the old zshenv file
+ # Move the old version into a zprofile script so the normal
+ # etc-update process will handle any changes.
+ if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
+ mv /etc/zsh/zshenv /etc/zsh/zprofile
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/zsh-completion and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ elog
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ elog
+ # see Bug 26776
+ ewarn
+ ewarn "If you are upgrading from zsh-4.0.x you may need to"
+ ewarn "remove all your old ~/.zcompdump files in order to use"
+ ewarn "completion. For more info see zcompsys manpage."
+ ewarn
+}