summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-08-12 21:36:34 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-08-12 21:36:34 +0000
commit1117b3363c592786978cf16bf38dc1b44a60d1cb (patch)
treed265d1073fd2e114f254110c7c81cab0c490c8c5 /app-shells
parentKeyword ~ppc and ~ppc64, bug #519170 (diff)
downloadgentoo-2-1117b3363c592786978cf16bf38dc1b44a60d1cb.tar.gz
gentoo-2-1117b3363c592786978cf16bf38dc1b44a60d1cb.tar.bz2
gentoo-2-1117b3363c592786978cf16bf38dc1b44a60d1cb.zip
Revbump to fix a segmentation fault with lastpipe. Removed old
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog10
-rw-r--r--app-shells/bash/bash-4.3_p22-r1.ebuild (renamed from app-shells/bash/bash-4.3_p18-r4.ebuild)5
-rw-r--r--app-shells/bash/files/bash-4.3-append-process-segfault.patch18
-rw-r--r--app-shells/bash/files/bash-4.3-here-doc-ps2-comsub.patch47
-rw-r--r--app-shells/bash/files/bash-4.3-lastpipe-nested-pipe-segfault.patch24
5 files changed, 29 insertions, 75 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index bdcf66a64181..1dda0a265e26 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.376 2014/08/02 02:21:26 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.377 2014/08/12 21:36:34 polynomial-c Exp $
+
+*bash-4.3_p22-r1 (12 Aug 2014)
+
+ 12 Aug 2014; Lars Wendler <polynomial-c@gentoo.org> -bash-4.3_p18-r4.ebuild,
+ +bash-4.3_p22-r1.ebuild, +files/bash-4.3-append-process-segfault.patch,
+ -files/bash-4.3-here-doc-ps2-comsub.patch,
+ -files/bash-4.3-lastpipe-nested-pipe-segfault.patch:
+ Revbump to fix a segmentation fault with lastpipe. Removed old.
*bash-4.3_p22 (02 Aug 2014)
diff --git a/app-shells/bash/bash-4.3_p18-r4.ebuild b/app-shells/bash/bash-4.3_p22-r1.ebuild
index 49d33d8c0443..22be599c7c5f 100644
--- a/app-shells/bash/bash-4.3_p18-r4.ebuild
+++ b/app-shells/bash/bash-4.3_p22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p18-r4.ebuild,v 1.1 2014/07/24 07:09:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p22-r1.ebuild,v 1.1 2014/08/12 21:36:34 polynomial-c Exp $
EAPI="4"
@@ -83,11 +83,10 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/*
- epatch "${FILESDIR}"/${PN}-4.3-here-doc-ps2-comsub.patch
epatch "${FILESDIR}"/${PN}-4.3-compat-lvl.patch
epatch "${FILESDIR}"/${PN}-4.3-parse-time-keyword.patch
- epatch "${FILESDIR}"/${PN}-4.3-lastpipe-nested-pipe-segfault.patch
epatch "${FILESDIR}"/${PN}-4.3-indirect-array-element.patch
+ epatch "${FILESDIR}"/${PN}-4.3-append-process-segfault.patch
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-append-process-segfault.patch b/app-shells/bash/files/bash-4.3-append-process-segfault.patch
new file mode 100644
index 000000000000..6c9b2e83067a
--- /dev/null
+++ b/app-shells/bash/files/bash-4.3-append-process-segfault.patch
@@ -0,0 +1,18 @@
+https://lists.gnu.org/archive/html/bug-bash/2014-08/msg00048.html
+
+*** ../bash-4.3-patched/execute_cmd.c 2014-07-30 10:26:52.000000000 -0400
+--- execute_cmd.c 2014-08-11 16:55:57.000000000 -0400
+***************
+*** 2406,2410 ****
+ {
+ #if defined (JOB_CONTROL)
+! append_process (savestring (the_printed_command), dollar_dollar_pid, exec_result, lastpipe_jid);
+ #endif
+ lstdin = wait_for (lastpid);
+--- 2433,2438 ----
+ {
+ #if defined (JOB_CONTROL)
+! if (INVALID_JOB (lastpipe_jid) == 0)
+! append_process (savestring (the_printed_command_except_trap), dollar_dollar_pid, exec_result, lastpipe_jid);
+ #endif
+ lstdin = wait_for (lastpid);
diff --git a/app-shells/bash/files/bash-4.3-here-doc-ps2-comsub.patch b/app-shells/bash/files/bash-4.3-here-doc-ps2-comsub.patch
deleted file mode 100644
index 0ccfd20117b0..000000000000
--- a/app-shells/bash/files/bash-4.3-here-doc-ps2-comsub.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-*** ../bash-4.3-patched/shell.h 2012-12-25 21:11:01.000000000 -0500
---- shell.h 2014-06-03 09:24:28.000000000 -0400
-***************
-*** 169,173 ****
- int expand_aliases;
- int echo_input_at_read;
-!
- } sh_parser_state_t;
-
---- 169,174 ----
- int expand_aliases;
- int echo_input_at_read;
-! int need_here_doc;
-!
- } sh_parser_state_t;
-
-*** ../bash-4.3-patched/parse.y 2014-05-14 09:16:40.000000000 -0400
---- parse.y 2014-04-30 09:27:59.000000000 -0400
-***************
-*** 2643,2647 ****
-
- r = 0;
-! while (need_here_doc)
- {
- parser_state |= PST_HEREDOC;
---- 2643,2647 ----
-
- r = 0;
-! while (need_here_doc > 0)
- {
- parser_state |= PST_HEREDOC;
-***************
-*** 6076,6079 ****
---- 6076,6080 ----
- ps->expand_aliases = expand_aliases;
- ps->echo_input_at_read = echo_input_at_read;
-+ ps->need_here_doc = need_here_doc;
-
- ps->token = token;
-***************
-*** 6124,6127 ****
---- 6125,6129 ----
- expand_aliases = ps->expand_aliases;
- echo_input_at_read = ps->echo_input_at_read;
-+ need_here_doc = ps->need_here_doc;
-
- FREE (token);
diff --git a/app-shells/bash/files/bash-4.3-lastpipe-nested-pipe-segfault.patch b/app-shells/bash/files/bash-4.3-lastpipe-nested-pipe-segfault.patch
deleted file mode 100644
index 200a84f1d491..000000000000
--- a/app-shells/bash/files/bash-4.3-lastpipe-nested-pipe-segfault.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-*** ../bash-4.3-patched/execute_cmd.c 2014-01-31 10:54:52.000000000 -0500
---- execute_cmd.c 2014-06-19 08:05:49.000000000 -0400
-***************
-*** 2410,2414 ****
- lstdin = wait_for (lastpid);
- #if defined (JOB_CONTROL)
-! exec_result = job_exit_status (lastpipe_jid);
- #endif
- unfreeze_jobs_list ();
---- 2425,2438 ----
- lstdin = wait_for (lastpid);
- #if defined (JOB_CONTROL)
-! /* If wait_for removes the job from the jobs table, use result of last
-! command as pipeline's exit status as usual. The jobs list can get
-! frozen and unfrozen at inconvenient times if there are multiple pipelines
-! running simultaneously. */
-! if (INVALID_JOB (lastpipe_jid) == 0)
-! exec_result = job_exit_status (lastpipe_jid);
-! else if (pipefail_opt)
-! exec_result = exec_result | lstdin; /* XXX */
-! /* otherwise we use exec_result */
-!
- #endif
- unfreeze_jobs_list ();