summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 22:46:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 22:46:14 +0000
commit004d3b9a89606096a017e879eb70b586361c2bba (patch)
treeb87747caf4be41061fd0e63e45d649be93d1b768 /app-shells
parentManual Manifest recommit (diff)
downloadgentoo-2-004d3b9a89606096a017e879eb70b586361c2bba.tar.gz
gentoo-2-004d3b9a89606096a017e879eb70b586361c2bba.tar.bz2
gentoo-2-004d3b9a89606096a017e879eb70b586361c2bba.zip
when linking ncurses, search $ROOT/usr/lib
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-3.0-r7.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-shells/bash/bash-3.0-r7.ebuild b/app-shells/bash/bash-3.0-r7.ebuild
index 5adb954eeabc..3fcd9e394b9e 100644
--- a/app-shells/bash/bash-3.0-r7.ebuild
+++ b/app-shells/bash/bash-3.0-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r7.ebuild,v 1.2 2004/11/12 14:36:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r7.ebuild,v 1.3 2004/12/07 22:46:14 vapier Exp $
inherit eutils flag-o-matic gnuconfig gcc
@@ -110,7 +110,7 @@ src_compile() {
--without-gnu-malloc \
${myconf} || die
# Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-L${ROOT}/usr/lib -Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake || die "make failed"
}