summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-13 14:01:08 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-13 14:01:08 +0000
commiteec00ef3ff2d5bc3d11d7a89780718a5b0d9905b (patch)
tree5f604988923180b94f8e4f27f4cb5675b7747a07 /app-shells/zsh
parentA patch to compile tcsh with glibc-2.2.2 (diff)
downloadgentoo-2-eec00ef3ff2d5bc3d11d7a89780718a5b0d9905b.tar.gz
gentoo-2-eec00ef3ff2d5bc3d11d7a89780718a5b0d9905b.tar.bz2
gentoo-2-eec00ef3ff2d5bc3d11d7a89780718a5b0d9905b.zip
FHS and dependencie fixes
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/files/digest-zsh-3.1.9-r11
-rw-r--r--app-shells/zsh/zsh-3.1.9-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/zsh/files/digest-zsh-3.1.9-r1 b/app-shells/zsh/files/digest-zsh-3.1.9-r1
new file mode 100644
index 000000000000..31b8f40ebef2
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-3.1.9-r1
@@ -0,0 +1 @@
+MD5 b69ed3f04d2a3eb676f8d2ace562270a zsh-3.1.9.tar.gz
diff --git a/app-shells/zsh/zsh-3.1.9-r1.ebuild b/app-shells/zsh/zsh-3.1.9-r1.ebuild
new file mode 100644
index 000000000000..ea8f2935c21e
--- /dev/null
+++ b/app-shells/zsh/zsh-3.1.9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-3.1.9-r1.ebuild,v 1.1 2001/04/13 14:01:08 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+SRC_URI="ftp://ftp.zsh.org/pub/${A}"
+HOMEPAGE="www.zsh.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man \
+ --libdir=/usr/lib --host=${CHOST}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D} mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib \
+ install.bin install.man install.modules
+
+ dodoc ChangeLog META-FAQ README
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+
+}
+
+
+
+