summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-21 12:49:14 +0000
committerParag Mehta <pm@gentoo.org>2001-07-21 12:49:14 +0000
commitb190ee2166f8820982e91c6a74b78bb2b941712c (patch)
treeb2933f94a1b51ae9be187f427ec55e3d990f79d9 /app-shells/zsh
parentmodifying the ebuild for proper installation. (diff)
downloadgentoo-2-b190ee2166f8820982e91c6a74b78bb2b941712c.tar.gz
gentoo-2-b190ee2166f8820982e91c6a74b78bb2b941712c.tar.bz2
gentoo-2-b190ee2166f8820982e91c6a74b78bb2b941712c.zip
modified zsh ebuild and removed old pur-ftpd and added new updated pure-ftpd version added.remove zsh & earlier pureftpd versoin from package.mask
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/zsh-4.0.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/zsh/zsh-4.0.2.ebuild b/app-shells/zsh/zsh-4.0.2.ebuild
new file mode 100644
index 000000000000..793b87db80ed
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# This ebuild by Parag Mehta <pm@gentoo.org>
+# /home/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.2.ebuild,v 1.1 2001/07/03 12:19:26 pm Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+SRC_URI="ftp://ftp.zsh.org/pub/${A}"
+HOMEPAGE="www.zsh.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man \
+ --libdir=/usr/lib --host=${CHOST} --infodir=/usr/share/info \
+ --enable-maildir-support --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv --enable-zshlogin=/etc/zsh/zshlogin \
+ --enable-zshrc=/etc/zsh/zshrc --enable-fndir=/usr/share \
+ --enable-function-subdirs
+ try make
+ try make check
+}
+
+src_install() {
+
+ try make prefix=${D} mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib fndir=${D}/usr/share \
+ install.bin install.man install.modules \
+ install.info
+
+ dodoc ChangeLog META-FAQ README INSTALL LICENCE config.modules
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+ dodir /etc/zsh
+ cp ${S}/StartupFiles/z* ${D}/etc/zsh
+
+}
+
+
+
+