summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-22 13:42:11 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-22 13:42:11 +0000
commit007f43a933174e66627ec37c8b6e946de4243c55 (patch)
treea6147d0580428a4610e2bbff9196eccdd4714cbd /app-shells/zsh
parentInitial import. Ebuild submitted by Jacob Martin <jmartin@chem.uga.edu>; bug ... (diff)
downloadgentoo-2-007f43a933174e66627ec37c8b6e946de4243c55.tar.gz
gentoo-2-007f43a933174e66627ec37c8b6e946de4243c55.tar.bz2
gentoo-2-007f43a933174e66627ec37c8b6e946de4243c55.zip
Fixed _init_d completion. Thanks to oberyno <oberyno@gmail.com>; bug #69997.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog6
-rw-r--r--app-shells/zsh/files/zsh-init.d-gentoo.diff36
2 files changed, 35 insertions, 7 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 6b97fc8265e5..2d286be36315 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.72 2005/02/15 07:06:51 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.73 2005/02/22 13:42:11 usata Exp $
+
+ 22 Feb 2005; Mamoru KOMACHI <usata@gentoo.org>
+ files/zsh-init.d-gentoo.diff:
+ Fixed _init_d completion. Thanks to oberyno <oberyno@gmail.com>; bug #69997.
15 Feb 2005; Guy Martin <gmsoft@gentoo.org> zsh-4.2.3.ebuild:
Stable on hppa.
diff --git a/app-shells/zsh/files/zsh-init.d-gentoo.diff b/app-shells/zsh/files/zsh-init.d-gentoo.diff
index 62612dc23d3b..28fabc7d3c74 100644
--- a/app-shells/zsh/files/zsh-init.d-gentoo.diff
+++ b/app-shells/zsh/files/zsh-init.d-gentoo.diff
@@ -1,11 +1,35 @@
-diff -urN zsh-4.2.1.ORIG/Completion/Unix/Command/_init_d zsh-4.2.1/Completion/Unix/Command/_init_d
---- zsh-4.2.1.ORIG/Completion/Unix/Command/_init_d 2003-05-15 18:25:21.000000000 +0900
-+++ zsh-4.2.1/Completion/Unix/Command/_init_d 2004-11-06 18:15:46.000000000 +0900
-@@ -23,6 +23,6 @@
+diff -urN zsh-4.2.4.ORIG/Completion/Unix/Command/_init_d zsh-4.2.4/Completion/Unix/Command/_init_d
+--- zsh-4.2.4.ORIG/Completion/Unix/Command/_init_d 2003-05-12 19:10:51.000000000 +0900
++++ zsh-4.2.4/Completion/Unix/Command/_init_d 2005-02-22 22:32:42.162337888 +0900
+@@ -1,6 +1,6 @@
+ #compdef -p */(init|rc[0-9S]#).d/*
+
+-local magic cmds what script
++local magic cmds what script opts
+
+ _compskip=all
+
+@@ -8,6 +8,8 @@
+
+ script=$words[1]
+ [[ $script = */* ]] || script=/etc/init.d/$script
++[[ ! -f $script ]] &&
++ { _message "${words[1]:t} is not an init script" && return }
+
+ # If the file starts with `#!' we hope that this is a shell script
+ # and get lines looking like <space>foo|bar) with the words in $what.
+@@ -22,7 +24,12 @@
+ #
# cmds=( ${${(j:|:s:|:)${(M)${(f)"$(< $script)"}:#[[:blank:]]#(\'|)[a-z_|]##\'|)\)}}//[^a-z_]} )
- (( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds ||
+-(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds ||
- cmds=(start stop)
-+ cmds=(start stop restart pause zap status)
++(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds
++opts=(start stop restart pause zap status ineed iuse needsme usesme broken)
++
++# If we didn't get $cmds from a zstyle, then read init script for opts.
++# If script doesn't specify opts, then default to the standard opts.
++(( $#cmds )) || cmds=( ${(eQz)${(M)${(f)"$( <$script)"}:#[[:blank:]]#opts=*}#*=} )
++(( $#cmds )) || cmds=($opts)
_sub_commands $cmds