summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2009-12-04 01:49:31 +0000
committerDawid Węgliński <cla@gentoo.org>2009-12-04 01:49:31 +0000
commitb8f02423a0c293cf0fa638c4018afc82df3162ed (patch)
tree618e82127633ff0fc3060e1da81f2d3ece279c8d /app-shells/zsh-completion
parent20091130 snapshot (diff)
downloadgentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.tar.gz
gentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.tar.bz2
gentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.zip
Improve eix completion
(Portage version: 2.2_rc52/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/zsh-completion')
-rw-r--r--app-shells/zsh-completion/ChangeLog8
-rw-r--r--app-shells/zsh-completion/files/zsh-completion-eix-20091203.patch63
-rw-r--r--app-shells/zsh-completion/zsh-completion-20091203.ebuild41
3 files changed, 111 insertions, 1 deletions
diff --git a/app-shells/zsh-completion/ChangeLog b/app-shells/zsh-completion/ChangeLog
index ed02d506fc84..56361d3d17b9 100644
--- a/app-shells/zsh-completion/ChangeLog
+++ b/app-shells/zsh-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/zsh-completion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/ChangeLog,v 1.39 2009/08/01 03:08:24 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/ChangeLog,v 1.40 2009/12/04 01:49:31 cla Exp $
+
+*zsh-completion-20091203 (04 Dec 2009)
+
+ 04 Dec 2009; Dawid Węgliński <cla@gentoo.org>
+ +zsh-completion-20091203.ebuild, +files/zsh-completion-eix-20091203.patch:
+ Improve eix completions
01 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
-zsh-completion-20060618.ebuild, -zsh-completion-20080110.ebuild:
diff --git a/app-shells/zsh-completion/files/zsh-completion-eix-20091203.patch b/app-shells/zsh-completion/files/zsh-completion-eix-20091203.patch
new file mode 100644
index 000000000000..1ef8c1afd49f
--- /dev/null
+++ b/app-shells/zsh-completion/files/zsh-completion-eix-20091203.patch
@@ -0,0 +1,63 @@
+diff -Naur zsh-completion-20080310.old/_eix zsh-completion-20080310/_eix
+--- zsh-completion-20080310.old/_eix 2008-03-10 14:25:10.000000000 +0100
++++ zsh-completion-20080310/_eix 2009-12-04 01:15:05.000000000 +0100
+@@ -19,6 +19,14 @@
+ '--dump[dump variables to stdout]'
+ '--dump-defaults[dump default values of variables]'
+ '--print[print the expanded value of a variable]'
++ '--print-all-useflags[print all IUSE words used in some version]'
++ '--print-all-keywords[print all KEYWORDS used in some version]'
++ '--print-all-slots[print all SLOT strings used in some version]'
++ '--print-all-provides[print all PROVIDE strings used in some package]'
++ '--print-all-licenses[print all LICENSE strings used in some package]'
++ '--print-world-sets[print the world sets]'
++ '--print-overlay-path[print the path of specified overlay]'
++ '--print-overlay-label[print label of specified overlay]'
+ )
+
+ global_special=(
+@@ -55,6 +63,12 @@
+ '--testing[Match packages with a testing or stable version]'
+ '--non-masked[Match packages with a non-masked version]'
+ '--system[Match system packages]'
++ '--installed-unstable[Match packages with a non-stable installed version]'
++ '--installed-testing[Match packages with a testing installed version]'
++ '--installed-masked[Match packages with a masked installed version]'
++ '--world[Match world packages]'
++ '--world-all[Match packages of world or of a world set]'
++ '--world-set[Match packages of a world set]'
+ {'(--overlay)-O','(-O)--overlay'}'[Match packages from overlays]'
+ '--in-overlay[OVERLAY Match packages from OVERLAY]'
+ '--only-in-overlay[OVERLAY Match packages only in OVERLAY]'
+@@ -62,8 +76,19 @@
+ '--installed-from-overlay[OVERLAY Packages installed from OVERLAY]'
+ '--installed-in-some-overlay[Packages with an installed version provided by some overlay]'
+ '--installed-in-overlay[OVERLAY Packages with an installed version provided from OVERLAY]'
+- '--fetch[Match packages with a fetch restriction]'
+- '--mirror[Match packages with a mirror restriction]'
++ '--restrict-fetch[Match packages with a fetch restriction]'
++ '--restrict-mirror[Match packages with a mirror restriction]'
++ '--restrict-primaryuri[Match packages with RESTRICT=primaryuri]'
++ '--restrict-binchecks[Match packages with RESTRICT=binchecks]'
++ '--restrict-strip[Match packages with RESTRICT=strip]'
++ '--restrict-test[Match packages with RESTRICT=test]'
++ '--restrict-userpriv[Match packages with RESTRICT=userpriv]'
++ '--restrict-installsources[Match packages with RESTRICT=installsources]'
++ '--restrict-bindist[Match packages with RESTRICT=bindist]'
++ '--properties-interactive[Match packages with PROPERTIES=interactive]'
++ '--properties-live[Match packages with PROPERTIES=live]'
++ '--properties-virtual[ Match packages with PROPERTIES=virtual]'
++ '--properties-set[Match packages with PROPERTIES=set]'
+ {'(--test-obsolete)-T','(-T)--test-obsolete'}'[Match packages with obsolete entries in /etc/portage/package.*]'
+ {'(--not)-!','(-!)--not'}'[(toggle) Invert the expression]'
+ {'(--pipe)-\\|','(-\\|)--pipe'}'[Use input from pipe of emerge -pv]'
+@@ -85,6 +110,9 @@
+ local_type_of_pattern=(
+ {'(--regex)-r','(-r)--regex'}'[Pattern is a regexp (default)]'
+ {'(--exact)-e','(-e)--exact'}'[Pattern is the exact string]'
++ {'(--substring)-z','(-z)--substring'}'[Pattern is a substring]'
++ {'(--begin)-b','(-b)--begin'}'[Pattern is the beginning of the string]'
++ '--end[Pattern is the end of the string]'
+ {'(--pattern)-p','(-p)--pattern'}'[Pattern is a wildcards-pattern]'
+ {'(--fuzzy)-f','(-f)--fuzzy'}'[Use fuzzy-search with a max. levenshtein-distance m (default: 2)]'
+ )
diff --git a/app-shells/zsh-completion/zsh-completion-20091203.ebuild b/app-shells/zsh-completion/zsh-completion-20091203.ebuild
new file mode 100644
index 000000000000..bab3162c808d
--- /dev/null
+++ b/app-shells/zsh-completion/zsh-completion-20091203.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/zsh-completion-20091203.ebuild,v 1.1 2009/12/04 01:49:31 cla Exp $
+
+inherit eutils
+
+MY_PV="20080310"
+DESCRIPTION="Programmable Completion for zsh (includes emerge and ebuild commands)"
+HOMEPAGE="http://gzc.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/gzc/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=app-shells/zsh-4.3.5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-eix-20091203.patch
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins _*
+
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make zsh-completion available"
+ elog "to your shell."
+ elog
+}