summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-08 03:52:04 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-08 03:52:04 +0000
commit3ee0ef4c2b54856619fa65506f6fdceb1e7a994b (patch)
tree2614f74866cae286c2514c2b56e2b60c5631ef14 /app-shells/squirrelsh
parentVersion bump (diff)
downloadgentoo-2-3ee0ef4c2b54856619fa65506f6fdceb1e7a994b.tar.gz
gentoo-2-3ee0ef4c2b54856619fa65506f6fdceb1e7a994b.tar.bz2
gentoo-2-3ee0ef4c2b54856619fa65506f6fdceb1e7a994b.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-shells/squirrelsh')
-rw-r--r--app-shells/squirrelsh/ChangeLog10
-rw-r--r--app-shells/squirrelsh/squirrelsh-1.2.7.ebuild48
2 files changed, 55 insertions, 3 deletions
diff --git a/app-shells/squirrelsh/ChangeLog b/app-shells/squirrelsh/ChangeLog
index 38d08a86e78f..20237ac8eb7d 100644
--- a/app-shells/squirrelsh/ChangeLog
+++ b/app-shells/squirrelsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/squirrelsh
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/squirrelsh/ChangeLog,v 1.9 2012/06/29 13:37:38 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/squirrelsh/ChangeLog,v 1.10 2013/01/08 03:52:04 blueness Exp $
+
+*squirrelsh-1.2.7 (08 Jan 2013)
+
+ 08 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +squirrelsh-1.2.7.ebuild:
+ Version bump
29 Jun 2012; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Removing eplumlee@yahoo.com as maintainer until he gets back to me
@@ -44,4 +49,3 @@
+squirrelsh-1.2.3.ebuild:
Initial commit. Ebuild written by Evan Plumlee <ed-209@hellburner.com>.
Proxied maintainer.
-
diff --git a/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild b/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
new file mode 100644
index 000000000000..529ce9651317
--- /dev/null
+++ b/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/squirrelsh/squirrelsh-1.2.7.ebuild,v 1.1 2013/01/08 03:52:04 blueness Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="An advanced, cross-platform object oriented scripting shell based
+on the squirrel scripting language"
+HOMEPAGE="http://squirrelsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-rename-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-no-strip.patch
+ epatch "${FILESDIR}"/${PN}-fix-in_LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-remove-forced-abi.patch
+ epatch "${FILESDIR}"/${PN}-no-docs.patch
+}
+
+src_configure() {
+ #This package uses a custom written configure script
+ ./configure --prefix="${D}"/usr \
+ --with-cc="$(tc-getCC)" \
+ --with-cpp="$(tc-getCXX)" \
+ --with-linker="$(tc-getCXX)" \
+ --libdir=/usr/"$(get_libdir)" \
+ --with-pcre="system" \
+ --with-squirrel="local" \
+ --with-mime=no || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman doc/${PN}.1
+ dodoc HISTORY INSTALL README
+ use doc && dodoc doc/*.pdf
+}