summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-31 03:58:31 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-31 03:58:31 +0000
commit30a483ae9341500ccbdb2a141b93e0b1a1f39969 (patch)
treecf600395418ef4d620b9f9a6cd888cae91344522 /app-shells/scsh
parentRemove old ebuilds; Hard mask amd64 -- there is no 64-bit support for now. (diff)
downloadgentoo-2-30a483ae9341500ccbdb2a141b93e0b1a1f39969.tar.gz
gentoo-2-30a483ae9341500ccbdb2a141b93e0b1a1f39969.tar.bz2
gentoo-2-30a483ae9341500ccbdb2a141b93e0b1a1f39969.zip
New upstream version; Remove old ebuilds; Hard mask amd64 -- there is no 64-bit support for now.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'app-shells/scsh')
-rw-r--r--app-shells/scsh/ChangeLog10
-rw-r--r--app-shells/scsh/files/digest-scsh-0.6.73
-rw-r--r--app-shells/scsh/scsh-0.6.7.ebuild44
3 files changed, 56 insertions, 1 deletions
diff --git a/app-shells/scsh/ChangeLog b/app-shells/scsh/ChangeLog
index 60e8e064d68d..9c3bd24a8c22 100644
--- a/app-shells/scsh/ChangeLog
+++ b/app-shells/scsh/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/scsh
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/ChangeLog,v 1.19 2006/01/05 17:53:39 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/ChangeLog,v 1.20 2006/08/31 03:58:31 mkennedy Exp $
+
+*scsh-0.6.7 (31 Aug 2006)
+
+ 31 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org> -scsh-0.6.1-r1.ebuild,
+ -scsh-0.6.3.ebuild, -scsh-0.6.4.ebuild, -scsh-0.6.5.ebuild,
+ +scsh-0.6.7.ebuild:
+ New upstream version; Remove old ebuilds; Hard mask amd64 -- there is no
+ 64-bit support for now.
05 Jan 2006; Matthew Kennedy <mkennedy@gentoo.org> scsh-0.6.6.ebuild:
Synchronize with recent scsh.eclass changes.
diff --git a/app-shells/scsh/files/digest-scsh-0.6.7 b/app-shells/scsh/files/digest-scsh-0.6.7
new file mode 100644
index 000000000000..85d92c6adb9e
--- /dev/null
+++ b/app-shells/scsh/files/digest-scsh-0.6.7
@@ -0,0 +1,3 @@
+MD5 69c88ca86a8aaaf0f87d253b99d339b5 scsh-0.6.7.tar.gz 4367439
+RMD160 f017c5a157cd1a3ad5daeaecba43ce84784c7e51 scsh-0.6.7.tar.gz 4367439
+SHA256 c4a9f7df2a0bb7a7aa3dafc918aa9e9a566d4ad33a55f0192889de172d1ddb7f scsh-0.6.7.tar.gz 4367439
diff --git a/app-shells/scsh/scsh-0.6.7.ebuild b/app-shells/scsh/scsh-0.6.7.ebuild
new file mode 100644
index 000000000000..ee4ea9b1b655
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.7.ebuild,v 1.1 2006/08/31 03:58:31 mkennedy Exp $
+
+inherit eutils scsh
+
+MV="${PV%*.*}"
+
+DESCRIPTION="Unix shell embedded in Scheme"
+HOMEPAGE="http://www.scsh.net/"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/${MV}/${P}.tar.gz"
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+
+src_unpack() {
+ # SCSH_LIB_DIRS='$SCSH_SCSH_PATH'
+ set_layout
+ set_path_variables
+ unpack ${A}
+ cd ${S}
+ if ! use scsh; then
+ epatch ${FILESDIR}/0.6.6-Makefile.in-doc-dir-gentoo.patch || die
+ fi
+}
+
+src_compile() {
+ scsh_conf="--prefix=/usr
+ --libdir=/usr/$(get_libdir)
+ --includedir=/usr/include
+ --with-lib-dirs-list=$(scsh_scsh_path)"
+ econf ${scsh_conf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50scsh <<EOF
+SCSH_LIB_DIRS='${SCSH_LIB_DIRS}'
+EOF
+}