summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-05 05:13:36 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-05 05:13:36 +0000
commitbccde2161070adefd616ba8d2ed0340c8d68056a (patch)
tree2e1b1d29c39f51237d8c30c4a37d3ff8d932e6de /app-shells/sandboxshell
parentuse /etc/init.d/functions.sh rather than /sbin/functions.sh (diff)
downloadgentoo-2-bccde2161070adefd616ba8d2ed0340c8d68056a.tar.gz
gentoo-2-bccde2161070adefd616ba8d2ed0340c8d68056a.tar.bz2
gentoo-2-bccde2161070adefd616ba8d2ed0340c8d68056a.zip
use /etc/init.d/functions.sh rather than /sbin/functions.sh
(Portage version: 2.1.2.5)
Diffstat (limited to 'app-shells/sandboxshell')
-rw-r--r--app-shells/sandboxshell/files/sandboxshell6
-rw-r--r--app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild12
2 files changed, 14 insertions, 4 deletions
diff --git a/app-shells/sandboxshell/files/sandboxshell b/app-shells/sandboxshell/files/sandboxshell
index a7c4dc2edfca..f93522a0812c 100644
--- a/app-shells/sandboxshell/files/sandboxshell
+++ b/app-shells/sandboxshell/files/sandboxshell
@@ -1,10 +1,10 @@
#!/bin/bash
# Written by vapier@gentoo.org
# public-domain code ... z0r ...
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell,v 1.4 2005/12/10 20:25:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell,v 1.5 2007/05/05 05:13:36 vapier Exp $
-. /sbin/functions.sh
-. /etc/profile
+. /etc/profile || exit 1
+. /etc/init.d/functions.sh || exit 1
# sanity checks ...
cd ${PWD} || {
diff --git a/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild b/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
index d777369291c1..b54318fafcc4 100644
--- a/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
+++ b/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild,v 1.1 2007/03/09 00:13:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild,v 1.2 2007/05/05 05:13:36 vapier Exp $
inherit eutils
@@ -22,9 +22,19 @@ RDEPEND=">sys-apps/portage-2.1.1
S=${WORKDIR}
src_install() {
+ insinto ${D}
+ newins "${FILESDIR}"/sandboxshell-r1.conf sandboxshell.conf
+return 0
dobin "${FILESDIR}"/sandboxshell || die
doman "${FILESDIR}"/sandboxshell.1
insinto /etc
newins "${FILESDIR}"/sandboxshell-r1.conf sandboxshell.conf
make_desktop_entry /usr/bin/sandboxshell
+ echo asdf > foo
+ dodoc foo
+ ln "${D}"/usr/share/doc/${PF}/{foo,blah}
+ echo foo > blah.html
+ dohtml blah.html
+ prepalldocs
+ tree -a "${D}"
}