summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-27 18:01:47 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-27 18:01:47 +0000
commit1e35eca3e0c7e1e42f0dc776e837efc80febd555 (patch)
treee76de1e2c530bbf0f546ffbe7328aa5f24f7a19b /app-shells/posh
parentwhitespace (diff)
downloadgentoo-2-1e35eca3e0c7e1e42f0dc776e837efc80febd555.tar.gz
gentoo-2-1e35eca3e0c7e1e42f0dc776e837efc80febd555.tar.bz2
gentoo-2-1e35eca3e0c7e1e42f0dc776e837efc80febd555.zip
Version bump. Backport a patch for glibc-2.16 compatibility (bug #432618).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'app-shells/posh')
-rw-r--r--app-shells/posh/ChangeLog8
-rw-r--r--app-shells/posh/files/posh-glibc-2.16.patch19
-rw-r--r--app-shells/posh/posh-0.10.2.ebuild6
-rw-r--r--app-shells/posh/posh-0.11.ebuild (renamed from app-shells/posh/posh-0.10.1.ebuild)6
4 files changed, 36 insertions, 3 deletions
diff --git a/app-shells/posh/ChangeLog b/app-shells/posh/ChangeLog
index c7ae87e036fa..e26edbb17f0b 100644
--- a/app-shells/posh/ChangeLog
+++ b/app-shells/posh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/posh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/ChangeLog,v 1.20 2012/06/19 14:25:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/ChangeLog,v 1.21 2012/11/27 18:01:45 mgorny Exp $
+
+*posh-0.11 (27 Nov 2012)
+
+ 27 Nov 2012; Michał Górny <mgorny@gentoo.org> +files/posh-glibc-2.16.patch,
+ +posh-0.11.ebuild, -posh-0.10.1.ebuild, posh-0.10.2.ebuild:
+ Version bump. Backport a patch for glibc-2.16 compatibility (bug #432618).
*posh-0.10.2 (19 Jun 2012)
diff --git a/app-shells/posh/files/posh-glibc-2.16.patch b/app-shells/posh/files/posh-glibc-2.16.patch
new file mode 100644
index 000000000000..8c29def10f72
--- /dev/null
+++ b/app-shells/posh/files/posh-glibc-2.16.patch
@@ -0,0 +1,19 @@
+Description: explicitly include sys/resource.h, for eglibc 2.16
+ sys/resource.h is no longer included by sys/wait.h
+ http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=d94a4670800de6e8f088b8630ad5142866127980
+Author: Stefano Rivera <stefanor@ubuntu.com>
+Last-Updated: 2012-11-07
+
+--- a/ksh_wait.h
++++ b/ksh_wait.h
+@@ -5,6 +5,10 @@
+ # include <sys/wait.h>
+ #endif
+
++#ifdef HAVE_SYS_RESOURCE_H
++# include <sys/resource.h>
++#endif
++
+ #ifndef POSIX_SYS_WAIT
+ /* Get rid of system macros (which probably use union wait) */
+ # undef WIFCORED
diff --git a/app-shells/posh/posh-0.10.2.ebuild b/app-shells/posh/posh-0.10.2.ebuild
index 4b264fd88809..e423f9bec102 100644
--- a/app-shells/posh/posh-0.10.2.ebuild
+++ b/app-shells/posh/posh-0.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/posh-0.10.2.ebuild,v 1.1 2012/06/19 14:25:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/posh-0.10.2.ebuild,v 1.2 2012/11/27 18:01:45 mgorny Exp $
EAPI=3
inherit autotools-utils
@@ -16,6 +16,10 @@ IUSE=""
RESTRICT=test
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-2.16.patch
+)
+
src_configure() {
myeconfargs=(
--exec-prefix=/
diff --git a/app-shells/posh/posh-0.10.1.ebuild b/app-shells/posh/posh-0.11.ebuild
index f62b526e09e4..de4a3b382b37 100644
--- a/app-shells/posh/posh-0.10.1.ebuild
+++ b/app-shells/posh/posh-0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/posh-0.10.1.ebuild,v 1.2 2012/06/19 14:25:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/posh/posh-0.11.ebuild,v 1.1 2012/11/27 18:01:45 mgorny Exp $
EAPI=3
inherit autotools-utils
@@ -16,6 +16,10 @@ IUSE=""
RESTRICT=test
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-2.16.patch
+)
+
src_configure() {
myeconfargs=(
--exec-prefix=/