summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-04-06 16:30:56 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-04-06 16:30:56 +0000
commit3db33be4e249d88bddec038de954f61d87a87696 (patch)
tree54916fc24f7e2534c86c0bd5eab087fabe2c5426 /app-shells/pdsh
parentDelete repeated lines from src_unpack in src_prepare (diff)
downloadgentoo-2-3db33be4e249d88bddec038de954f61d87a87696.tar.gz
gentoo-2-3db33be4e249d88bddec038de954f61d87a87696.tar.bz2
gentoo-2-3db33be4e249d88bddec038de954f61d87a87696.zip
Unbundle libtool and bump EAPI. Thanks to ssuominen for tracking down the patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/pdsh')
-rw-r--r--app-shells/pdsh/ChangeLog11
-rw-r--r--app-shells/pdsh/files/pdsh-2.18-unbundle-libtool.patch56
-rw-r--r--app-shells/pdsh/pdsh-2.18-r1.ebuild62
3 files changed, 127 insertions, 2 deletions
diff --git a/app-shells/pdsh/ChangeLog b/app-shells/pdsh/ChangeLog
index f459ca53cd60..1d2267597423 100644
--- a/app-shells/pdsh/ChangeLog
+++ b/app-shells/pdsh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/pdsh
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.14 2009/04/16 20:50:43 jsbronder Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/ChangeLog,v 1.15 2010/04/06 16:30:56 jsbronder Exp $
+
+*pdsh-2.18-r1 (06 Apr 2010)
+
+ 06 Apr 2010; Justin Bronder <jsbronder@gentoo.org> +pdsh-2.18-r1.ebuild,
+ +files/pdsh-2.18-unbundle-libtool.patch:
+ Unbundle libtool and bump EAPI. Thanks to ssuominen for tracking down the
+ patch.
*pdsh-2.18 (16 Apr 2009)
diff --git a/app-shells/pdsh/files/pdsh-2.18-unbundle-libtool.patch b/app-shells/pdsh/files/pdsh-2.18-unbundle-libtool.patch
new file mode 100644
index 000000000000..e73fb12d2e79
--- /dev/null
+++ b/app-shells/pdsh/files/pdsh-2.18-unbundle-libtool.patch
@@ -0,0 +1,56 @@
+From d055c4e9e2d414c9d51f7a6f2cf51cedfc79260f Mon Sep 17 00:00:00 2001
+From: Justin Bronder <jsbronder@gmail.com>
+Date: Tue, 6 Apr 2010 11:48:28 -0400
+Subject: [PATCH] unbundle libtool
+
+Bundled libltdl is vulnerable, CVE-2009-3736.
+Patch grabbed from Debian:
+http://ftp.de.debian.org/debian/pool/main/p/pdsh/pdsh_2.18-6.debian.tar.gz
+---
+ configure.ac | 6 ++++--
+ src/pdsh/Makefile.am | 5 ++---
+ 2 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2680344..196356b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,8 +38,10 @@ AC_DEBUG
+ # Libtool and ltld.[ch] support
+ #
+ AC_LIBTOOL_DLOPEN
+-AC_PROG_LIBTOOL
+-AC_LIB_LTDL
++LT_INIT
++AC_SUBST(LT_CURRENT)
++AC_SUBST(LT_REVISION)
++AC_SUBST(LT_AGE)
+
+ AM_CONDITIONAL(WITH_GNU_LD, test "$with_gnu_ld" = "yes")
+
+diff --git a/src/pdsh/Makefile.am b/src/pdsh/Makefile.am
+index dfc48a3..beac854 100644
+--- a/src/pdsh/Makefile.am
++++ b/src/pdsh/Makefile.am
+@@ -14,8 +14,7 @@ if WITH_STATIC_MODULES
+ MODULE_LIBS = $(top_builddir)/src/modules/libmods.la
+ else
+ MODULE_FLAGS = -export-dynamic $(AIX_PDSH_LDFLAGS)
+-LTDL_FILES = ltdl.h ltdl.c
+-LTDL_LDADD = $(LIBADD_DL)
++LTDL_LDADD = $(LIBADD_DL) -lltdl
+ endif
+
+ pdsh_LDADD = $(READLINE_LIBS) $(LTDL_LDADD)
+@@ -25,7 +24,7 @@ pdsh_LDFLAGS = $(MODULE_LIBS) $(MODULE_FLAGS) \
+ pdsh_inst_LDADD = $(pdsh_LDADD)
+ pdsh_inst_LDFLAGS = $(pdsh_LDFLAGS)
+
+-pdsh_SOURCES = $(PDSH_SOURCES) $(LTDL_FILES)
++pdsh_SOURCES = $(PDSH_SOURCES)
+ pdsh_inst_SOURCES = $(pdsh_SOURCES)
+ nodist_pdsh_SOURCES = testconfig.c
+ nodist_pdsh_inst_SOURCES = config.c
+--
+1.6.6.2
+
diff --git a/app-shells/pdsh/pdsh-2.18-r1.ebuild b/app-shells/pdsh/pdsh-2.18-r1.ebuild
new file mode 100644
index 000000000000..b2d04c19547c
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.18-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.18-r1.ebuild,v 1.1 2010/04/06 16:30:56 jsbronder Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="A high-performance, parallel remote shell utility."
+HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt readline rsh"
+RDEPEND="crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+
+# Feel free to debug the test suite. Running the tests
+# by hand instead of using pdsh.exp seems to print out
+# what is expected, so the error is most likely in the
+# testsuite itself.
+# You'll also need dev-util/dejagnu
+RESTRICT="test"
+
+pkg_setup() {
+ local m
+ local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
+
+ PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
+ MODULE_CONFIG=""
+ for m in ${PDSH_MODULE_LIST}; do
+ if [[ "${valid_modules}" == *:${m}:* ]]; then
+ MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
+ fi
+ done
+
+ elog "Building ${PF} with the following modules:"
+ elog " ${PDSH_MODULE_LIST}"
+ elog "This list can be changed in /etc/make.conf by setting"
+ elog "PDSH_MODULE_LIST=\"module1 module2...\""
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/pdsh-2.18-unbundle-libtool.patch || die
+ eautoreconf || die
+}
+
+src_configure() {
+ econf ${MODULE_CONFIG} \
+ --with-machines \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}