summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-09 15:14:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-09 15:14:51 +0000
commit92e774659af3c228465298a5cc511861145aa483 (patch)
tree84bf6e230aef03034036e49c3cac630dba80c403 /app-shells/localshell
parentFix building with GLIBC 2.10+ wrt #270845. (diff)
downloadgentoo-2-92e774659af3c228465298a5cc511861145aa483.tar.gz
gentoo-2-92e774659af3c228465298a5cc511861145aa483.tar.bz2
gentoo-2-92e774659af3c228465298a5cc511861145aa483.zip
Fix building with GLIBC 2.10+ wrt #277174.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/localshell')
-rw-r--r--app-shells/localshell/ChangeLog6
-rw-r--r--app-shells/localshell/files/localshell-1.3.1-glibc-2.10.patch12
-rw-r--r--app-shells/localshell/localshell-1.3.1.ebuild13
3 files changed, 26 insertions, 5 deletions
diff --git a/app-shells/localshell/ChangeLog b/app-shells/localshell/ChangeLog
index ffd32fa18286..88e0e2f26ff6 100644
--- a/app-shells/localshell/ChangeLog
+++ b/app-shells/localshell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/localshell
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.10 2009/01/09 02:33:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.11 2009/08/09 15:14:51 ssuominen Exp $
+
+ 09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ localshell-1.3.1.ebuild, +files/localshell-1.3.1-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #277174.
09 Jan 2009; Robin H. Johnson <robbat2@gentoo.org> localshell-1.1.ebuild,
localshell-1.2.ebuild:
diff --git a/app-shells/localshell/files/localshell-1.3.1-glibc-2.10.patch b/app-shells/localshell/files/localshell-1.3.1-glibc-2.10.patch
new file mode 100644
index 000000000000..7bdd8f9a8d1f
--- /dev/null
+++ b/app-shells/localshell/files/localshell-1.3.1-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur localshell-1.3.1.orig/src/config.cxx localshell-1.3.1/src/config.cxx
+--- localshell-1.3.1.orig/src/config.cxx 2009-01-09 03:40:11.000000000 +0200
++++ localshell-1.3.1/src/config.cxx 2009-08-09 18:15:17.000000000 +0300
+@@ -121,7 +121,7 @@
+ // PRIORITY,SHELL,ALLOWED
+ long priority = atol(argvalue);
+
+- char* shell = strstr(argvalue,",");
++ char* shell = const_cast<char*> (strstr(argvalue,","));
+ if(NULL == shell || '\0' == shell[1] ) {
+ fprintf(stderr,"%s: badly formatted entry (shell):%s\n",PACKAGE,argvalue);
+ return EINVAL;
diff --git a/app-shells/localshell/localshell-1.3.1.ebuild b/app-shells/localshell/localshell-1.3.1.ebuild
index 25d1edf21c87..29f3b4bb31e9 100644
--- a/app-shells/localshell/localshell-1.3.1.ebuild
+++ b/app-shells/localshell/localshell-1.3.1.ebuild
@@ -1,18 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.3.1.ebuild,v 1.1 2009/01/09 02:14:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.3.1.ebuild,v 1.2 2009/08/09 15:14:51 ssuominen Exp $
-inherit base
+inherit base eutils
DESCRIPTION="Localshell allows per-user/group local control of shell execution."
HOMEPAGE="http://oss.orbis-terrarum.net/localshell/"
SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="virtual/libc"
-#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
src_compile() {
# this is a shell, it needs to be in /bin