summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-13 23:58:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-13 23:58:49 +0000
commit170f8877cf29faa6a7a3676b9b36af887e8abb97 (patch)
treedce6c6b36e082a66bd4effa185af0bb6c89904a4 /app-shells/localshell
parentAdd ~sparc keyword (diff)
downloadgentoo-2-170f8877cf29faa6a7a3676b9b36af887e8abb97.tar.gz
gentoo-2-170f8877cf29faa6a7a3676b9b36af887e8abb97.tar.bz2
gentoo-2-170f8877cf29faa6a7a3676b9b36af887e8abb97.zip
Add patch to build with GCC 4.3, thanks to Bert Karwatzki in bug #250713.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'app-shells/localshell')
-rw-r--r--app-shells/localshell/ChangeLog8
-rw-r--r--app-shells/localshell/files/localshell-1.2+gcc-4.3.patch45
-rw-r--r--app-shells/localshell/localshell-1.2.ebuild8
3 files changed, 57 insertions, 4 deletions
diff --git a/app-shells/localshell/ChangeLog b/app-shells/localshell/ChangeLog
index 1b1243997354..bb420fa009b6 100644
--- a/app-shells/localshell/ChangeLog
+++ b/app-shells/localshell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/localshell
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.7 2007/04/22 13:56:38 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.8 2008/12/13 23:58:49 flameeyes Exp $
+
+ 13 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/localshell-1.2+gcc-4.3.patch, localshell-1.2.ebuild:
+ Add patch to build with GCC 4.3, thanks to Bert Karwatzki in bug #250713.
22 Apr 2007; Tobias Scherbaum <dertobi123@gentoo.org>
localshell-1.2.ebuild:
diff --git a/app-shells/localshell/files/localshell-1.2+gcc-4.3.patch b/app-shells/localshell/files/localshell-1.2+gcc-4.3.patch
new file mode 100644
index 000000000000..9bd2aeecd70c
--- /dev/null
+++ b/app-shells/localshell/files/localshell-1.2+gcc-4.3.patch
@@ -0,0 +1,45 @@
+diff -aur localshell-1.2.old/src/common.cxx localshell-1.2/src/common.cxx
+--- localshell-1.2.old/src/common.cxx 2008-12-12 20:03:48.000000000 +0100
++++ localshell-1.2/src/common.cxx 2008-12-12 20:15:31.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "structures.hh"
+ #include "common.hh"
+ #include <fstream>
++#include <cstring>
+ using namespace std;
+
+ bool match_user(uid_t uid, gid_t gid) {
+diff -aur localshell-1.2.old/src/config.cxx localshell-1.2/src/config.cxx
+--- localshell-1.2.old/src/config.cxx 2008-12-12 20:03:48.000000000 +0100
++++ localshell-1.2/src/config.cxx 2008-12-12 20:15:07.000000000 +0100
+@@ -10,6 +10,8 @@
+ #include <fstream>
+ #include <map>
+ #include <vector>
++#include <cstring>
++#include <cstdlib>
+ using namespace std;
+
+ int load_config( const char *cfg_filename, configuration &conf) {
+diff -aur localshell-1.2.old/src/config.hh localshell-1.2/src/config.hh
+--- localshell-1.2.old/src/config.hh 2008-12-12 20:03:48.000000000 +0100
++++ localshell-1.2/src/config.hh 2008-12-12 20:14:00.000000000 +0100
+@@ -2,6 +2,7 @@
+ #ifndef _CONFIG_HH_
+ #define _CONFIG_HH_
+ #include "structures.hh"
++#include <fstream>
+
+ int load_config( const char *cfg_filename, configuration &conf);
+ int parse_config(fstream &fs, configuration &conf);
+diff -aur localshell-1.2.old/src/localshell.cxx localshell-1.2/src/localshell.cxx
+--- localshell-1.2.old/src/localshell.cxx 2008-12-12 20:03:48.000000000 +0100
++++ localshell-1.2/src/localshell.cxx 2008-12-12 20:04:14.000000000 +0100
+@@ -10,6 +10,7 @@
+
+ #include <map>
+ #include <vector>
++#include <cstring>
+ using namespace std;
+
+ int main(int argc, char** argv) {
diff --git a/app-shells/localshell/localshell-1.2.ebuild b/app-shells/localshell/localshell-1.2.ebuild
index 49fcf93cfad0..5249334ab018 100644
--- a/app-shells/localshell/localshell-1.2.ebuild
+++ b/app-shells/localshell/localshell-1.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.2.ebuild,v 1.5 2007/04/22 13:56:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.2.ebuild,v 1.6 2008/12/13 23:58:49 flameeyes Exp $
+
+inherit base
DESCRIPTION="Localshell allows per-user/group local control of shell execution."
HOMEPAGE="http://research.iat.sfu.ca/custom-software/localshell/"
@@ -12,6 +14,8 @@ IUSE=""
DEPEND="virtual/libc"
#RDEPEND=""
+PATCHES=( "${FILESDIR}/${P}+gcc-4.3.patch" )
+
src_compile() {
# this is a shell, it needs to be in /bin
econf --bindir=/bin --sysconfdir=/etc || die "econf failed"