summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-06-13 02:26:31 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-06-13 02:26:31 +0000
commite959dd5b3865ee899cfc5b0a60186fa3e03370be (patch)
tree672e8ac00dbe33636906599acb8e123d40b94583 /app-shells/gentoo-bashcomp
parentAmarok utils require Qt4, drop implicit Qt dep caused by OPENGL_REQUIRED and ... (diff)
downloadgentoo-2-e959dd5b3865ee899cfc5b0a60186fa3e03370be.tar.gz
gentoo-2-e959dd5b3865ee899cfc5b0a60186fa3e03370be.tar.bz2
gentoo-2-e959dd5b3865ee899cfc5b0a60186fa3e03370be.zip
Version bump to fix bugs: 298919, 298916, 301582, 269498, 287092. Add Gentoo Prefix support.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog9
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20100613.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index a7edcf9c37ba..89cda7b8808c 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/gentoo-bashcomp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.41 2010/01/09 15:11:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.42 2010/06/13 02:26:31 darkside Exp $
+
+*gentoo-bashcomp-20100613 (13 Jun 2010)
+
+ 13 Jun 2010; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-bashcomp-20100613.ebuild:
+ Version bump to fix bugs: 298919, 298916, 301582, 269498, 287092. Add
+ Gentoo Prefix support.
09 Jan 2010; Alexis Ballier <aballier@gentoo.org>
gentoo-bashcomp-20091225.ebuild:
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20100613.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20100613.ebuild
new file mode 100644
index 000000000000..e9a1250c70cc
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20100613.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20100613.ebuild,v 1.1 2010/06/13 02:26:31 darkside Exp $
+
+EAPI=3
+inherit prefix
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, repoman, layman, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~darkside/tmp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_prepare() {
+ eprefixify gentoo
+}
+
+src_compile() { :; } # There is a useless Makefile in the distfile
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "failed to install gentoo module"
+ doins repoman || die "failed to install repoman module"
+ doins layman || die "failed to install layman module"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide. (and/or repoman instead of gentoo if you use"
+ elog "repoman frequently)"
+}