summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-06 09:42:36 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-06 09:42:36 +0000
commitc7012faa4cede26ed25e8d56f6e6403e4044c438 (patch)
treef5309f865bf36ecfdf8b079f8c5addeb761abc28 /app-shells/gentoo-bashcomp
parentarm stable, bug #427544 (diff)
downloadgentoo-2-c7012faa4cede26ed25e8d56f6e6403e4044c438.tar.gz
gentoo-2-c7012faa4cede26ed25e8d56f6e6403e4044c438.tar.bz2
gentoo-2-c7012faa4cede26ed25e8d56f6e6403e4044c438.zip
Fix breakage after /etc/make.globals, bug #431034.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog9
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index 31bc80671fdb..e9ce06442964 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/gentoo-bashcomp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.46 2012/05/04 11:07:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.47 2012/10/06 09:42:36 pacho Exp $
+
+*gentoo-bashcomp-20101217-r1 (06 Oct 2012)
+
+ 06 Oct 2012; Pacho Ramos <pacho@gentoo.org>
+ +gentoo-bashcomp-20101217-r1.ebuild:
+ Fix breakage after /etc/make.globals, bug #431034.
04 May 2012; Alexis Ballier <aballier@gentoo.org>
gentoo-bashcomp-20101217.ebuild:
@@ -219,4 +225,3 @@
+gentoo-bashcomp-20050316.ebuild:
New release; broken out from app-shells/bash-completion and into its own
ebuild.
-
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
new file mode 100644
index 000000000000..bc0d0c1018a0
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild,v 1.1 2012/10/06 09:42:36 pacho Exp $
+
+EAPI=4
+inherit eutils prefix
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, repoman, layman, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~darkside/tmp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-make_globals.patch" #431034
+ eprefixify gentoo
+}
+
+src_compile() { :; } # There is a useless Makefile in the distfile
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "failed to install gentoo module"
+ doins repoman || die "failed to install repoman module"
+ doins layman || die "failed to install layman module"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide. (and/or repoman instead of gentoo if you use"
+ elog "repoman frequently)"
+}