summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-07-08 20:29:07 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-07-08 20:29:07 +0000
commit4d2b4b39e8fbab0739f7febd4beea581e096c3db (patch)
tree235d046824d351d185ca8cace60780f32f3b9482 /app-shells/fish
parentRevision bump adds upstream patch to fix the changed bug url by git migration. (diff)
downloadgentoo-2-4d2b4b39e8fbab0739f7febd4beea581e096c3db.tar.gz
gentoo-2-4d2b4b39e8fbab0739f7febd4beea581e096c3db.tar.bz2
gentoo-2-4d2b4b39e8fbab0739f7febd4beea581e096c3db.zip
Version bump (bug #470144)
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/ChangeLog9
-rw-r--r--app-shells/fish/fish-2.0.0.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index ea3c9c35c95b..254c4d648736 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/fish
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.55 2012/11/29 04:05:09 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.56 2013/07/08 20:29:07 polynomial-c Exp $
+
+*fish-2.0.0 (08 Jul 2013)
+
+ 08 Jul 2013; Lars Wendler <polynomial-c@gentoo.org> +fish-2.0.0.ebuild:
+ Non-maintainer commit: Version bump (bug #470144).
29 Nov 2012; Jeff Horelick <jdhore@gentoo.org> metadata.xml:
Adopt fish
diff --git a/app-shells/fish/fish-2.0.0.ebuild b/app-shells/fish/fish-2.0.0.ebuild
new file mode 100644
index 000000000000..cf49112fcf69
--- /dev/null
+++ b/app-shells/fish/fish-2.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.0.0.ebuild,v 1.1 2013/07/08 20:29:07 polynomial-c Exp $
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Have fun!"
+}