summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-14 18:55:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-14 18:55:09 +0000
commitcd3189fd187a8bdcb72fc291e656feb29441026c (patch)
treee5fb389284b7c5164189dd11fa43726aa0662107 /app-shells/bash
parentstable on amd64 and ppc (diff)
downloadgentoo-2-cd3189fd187a8bdcb72fc291e656feb29441026c.tar.gz
gentoo-2-cd3189fd187a8bdcb72fc291e656feb29441026c.tar.bz2
gentoo-2-cd3189fd187a8bdcb72fc291e656feb29441026c.zip
dont use gcc eclass anymore
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/bash-2.05b-r11.ebuild8
-rw-r--r--app-shells/bash/bash-3.0-r7.ebuild8
-rw-r--r--app-shells/bash/bash-3.0-r8.ebuild8
3 files changed, 9 insertions, 15 deletions
diff --git a/app-shells/bash/bash-2.05b-r11.ebuild b/app-shells/bash/bash-2.05b-r11.ebuild
index efb101e13fb9..a123c90ffdff 100644
--- a/app-shells/bash/bash-2.05b-r11.ebuild
+++ b/app-shells/bash/bash-2.05b-r11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r11.ebuild,v 1.5 2005/01/01 15:56:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r11.ebuild,v 1.6 2005/05/14 18:55:09 vapier Exp $
-inherit eutils flag-o-matic gnuconfig gcc
+inherit eutils flag-o-matic toolchain-funcs
# Official patches
PLEVEL="x002 x003 x004 x005 x006 x007"
@@ -65,8 +65,6 @@ src_unpack() {
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
- gnuconfig_update
-
sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
@@ -89,7 +87,7 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
echo 'int main(){}' > ${T}/term-test.c
- if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
export bash_cv_termcap_lib=gnutermcap
else
export bash_cv_termcap_lib=libcurses
diff --git a/app-shells/bash/bash-3.0-r7.ebuild b/app-shells/bash/bash-3.0-r7.ebuild
index e3d072f670a5..62539a818090 100644
--- a/app-shells/bash/bash-3.0-r7.ebuild
+++ b/app-shells/bash/bash-3.0-r7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r7.ebuild,v 1.4 2005/01/01 15:56:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r7.ebuild,v 1.5 2005/05/14 18:55:09 vapier Exp $
-inherit eutils flag-o-matic gnuconfig gcc
+inherit eutils flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-3.0-patches/
@@ -74,8 +74,6 @@ src_unpack() {
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
- gnuconfig_update
-
sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
@@ -98,7 +96,7 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
echo 'int main(){}' > ${T}/term-test.c
- if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
export bash_cv_termcap_lib=gnutermcap
else
export bash_cv_termcap_lib=libcurses
diff --git a/app-shells/bash/bash-3.0-r8.ebuild b/app-shells/bash/bash-3.0-r8.ebuild
index f424dd4f52f3..5c5f42ec72b2 100644
--- a/app-shells/bash/bash-3.0-r8.ebuild
+++ b/app-shells/bash/bash-3.0-r8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r8.ebuild,v 1.1 2005/02/10 02:53:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r8.ebuild,v 1.2 2005/05/14 18:55:09 vapier Exp $
-inherit eutils flag-o-matic gnuconfig gcc
+inherit eutils flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-3.0-patches/
@@ -71,8 +71,6 @@ src_unpack() {
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
- gnuconfig_update
-
sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
@@ -95,7 +93,7 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
echo 'int main(){}' > ${T}/term-test.c
- if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
export bash_cv_termcap_lib=gnutermcap
else
export bash_cv_termcap_lib=libcurses