summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-03 22:26:45 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-03 22:26:45 +0000
commit93ae891410488e75b222e5085109d36cb26bdd96 (patch)
tree63d7ea98027fd7f213e9843fac3eb85189c48882 /app-shells/bash-completion
parentdobashcomp => newbashcomp. (diff)
downloadgentoo-2-93ae891410488e75b222e5085109d36cb26bdd96.tar.gz
gentoo-2-93ae891410488e75b222e5085109d36cb26bdd96.tar.bz2
gentoo-2-93ae891410488e75b222e5085109d36cb26bdd96.zip
Version bump (bug #395091).
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog7
-rw-r--r--app-shells/bash-completion/bash-completion-2.1.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 551b973793f6..ee5bf45182af 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.247 2013/06/02 08:43:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.248 2013/06/03 22:26:45 jer Exp $
+
+*bash-completion-2.1 (03 Jun 2013)
+
+ 03 Jun 2013; Jeroen Roovers <jer@gentoo.org> +bash-completion-2.1.ebuild:
+ Version bump (bug #395091).
02 Jun 2013; Agostino Sarubbo <ago@gentoo.org> bash-completion-1.3-r2.ebuild:
Stable for sh, wrt bug #468554
diff --git a/app-shells/bash-completion/bash-completion-2.1.ebuild b/app-shells/bash-completion/bash-completion-2.1.ebuild
new file mode 100644
index 000000000000..13cfe47fd3b6
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-2.1.ebuild,v 1.1 2013/06/03 22:26:45 jer Exp $
+
+EAPI=5
+inherit prefix
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect
+ || ( >=app-shells/bash-3.2 app-shells/zsh )
+ sys-apps/miscfiles"
+PDEPEND="app-shells/gentoo-bashcomp"
+
+src_prepare() {
+ cp "${FILESDIR}"/bash-completion.sh-gentoo-1.2 "${T}"/bash-completion.sh || die
+ eprefixify "${T}"/bash-completion.sh
+
+ find completions -name 'Makefile*' -exec rm -f {} +
+
+ # Part of >=sys-apps/util-linux-2.23 wrt #468544
+ rm -f completions/rtcwake
+
+ # app-editors/vim-core:
+ rm -f completions/xxd
+}
+
+src_configure() { :; } # no-op
+src_compile() { :; } # no-op
+
+src_install() {
+ # Gentoo specific bash-completion.sh file.
+ insinto /etc/profile.d
+ doins "${T}"/bash-completion.sh
+
+ # All files from contrib/ in source package get installed
+ insinto /usr/share/bash-completion
+ doins -r "${S}"/completions/*
+
+ awk -v D="$ED" '
+ BEGIN { out=".pre" }
+ /^# A lot of the following one-liners/ { out="base" }
+ /^# start of section containing completion functions called by other functions/ { out=".pre" }
+ /^# start of section containing completion functions for external programs/ { out="base" }
+ /^# source completion directory/ { out="" }
+ /^unset -f have/ { out=".post" }
+ out != "" { print > D"/usr/share/bash-completion/"out }' \
+ bash_completion || die "failed to split bash_completion"
+
+ dodoc AUTHORS CHANGES README
+
+ # This is backported from upstream 2.0 release. You can stop installing
+ # this file after 2.0 is in Portage and use the one from the tarball
+ # instead.
+ # Installed to datadir instead of libdir because bash-completion(s)
+ # are not ELF files.
+ insinto /usr/share/pkgconfig
+ doins "${FILESDIR}"/bash-completion.pc
+}
+
+pkg_postinst() {
+ if ! has_version "${CATEGORY}/${PN}"; then
+ elog "Any user can enable the module completions without editing their"
+ elog ".bashrc by running:"
+ elog
+ elog " eselect bashcomp enable <module>"
+ elog
+ elog "The system administrator can also be enable this globally with"
+ elog
+ elog " eselect bashcomp enable --global <module>"
+ elog
+ elog "Make sure you at least enable the base module! Additional completion"
+ elog "modules can be found by running"
+ elog
+ elog " eselect bashcomp list"
+ elog
+ elog "If you use non-login shells you still need to source"
+ elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
+ fi
+
+ if has_version 'app-shells/zsh' ; then
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}