summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-12-22 23:47:00 +0000
committerMichael Weber <xmw@gentoo.org>2010-12-22 23:47:00 +0000
commit0127e9ca56824194e138584733dbf4163596eb56 (patch)
tree2cf78ca448e63ec44b951194e5a30d83fc1ff071 /app-shells/autojump
parentVersion bump (diff)
downloadgentoo-2-0127e9ca56824194e138584733dbf4163596eb56.tar.gz
gentoo-2-0127e9ca56824194e138584733dbf4163596eb56.tar.bz2
gentoo-2-0127e9ca56824194e138584733dbf4163596eb56.zip
Version bump, python3 now supported.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/ChangeLog7
-rw-r--r--app-shells/autojump/autojump-14.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index 1988fe2b2dc7..3460709a319e 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.1 2010/10/26 22:15:00 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.2 2010/12/22 23:47:00 xmw Exp $
+
+*autojump-14 (22 Dec 2010)
+
+ 22 Dec 2010; Michael Weber <xmw@gentoo.org> +autojump-14.ebuild:
+ Version bump, python3 now supported.
*autojump-13 (26 Oct 2010)
diff --git a/app-shells/autojump/autojump-14.ebuild b/app-shells/autojump/autojump-14.ebuild
new file mode 100644
index 000000000000..2345ea9ffbf8
--- /dev/null
+++ b/app-shells/autojump/autojump-14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-14.ebuild,v 1.1 2010/12/22 23:47:00 xmw Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+MY_P=${PN}_v${PV}
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion gtk zsh-completion"
+
+RDEPEND="gtk? ( dev-python/pygtk:2 )
+ bash-completion? ( >=app-shells/bash-4 )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dobin autojump || die
+
+ if use gtk ; then
+ dobin jumpapplet || die
+ insinto /usr/share/${PN}
+ doins icon.png || die
+ fi
+
+ insinto /etc/profile.d
+ doins ${PN}.sh || die
+
+ if use bash-completion ; then
+ doins ${PN}.bash || die
+ fi
+
+ if use zsh-completion ; then
+ doins ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ doins _j || die
+ fi
+
+ doman ${PN}.1 || die
+ dodoc README.rst || die
+}