summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:25:18 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:25:18 +0000
commitc93b5d8ab3d121ce66ab8be26bb67072b7697878 (patch)
tree059a2dbb758217803b37a666dbf18a601258ecce /app-sci
parentCloses #9315. (diff)
downloadgentoo-2-c93b5d8ab3d121ce66ab8be26bb67072b7697878.tar.gz
gentoo-2-c93b5d8ab3d121ce66ab8be26bb67072b7697878.tar.bz2
gentoo-2-c93b5d8ab3d121ce66ab8be26bb67072b7697878.zip
Initial import.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/foldingathome/ChangeLog8
-rw-r--r--app-sci/foldingathome/files/digest-foldingathome-3.141
-rw-r--r--app-sci/foldingathome/files/folding-init.d16
-rw-r--r--app-sci/foldingathome/foldingathome-3.14.ebuild43
4 files changed, 68 insertions, 0 deletions
diff --git a/app-sci/foldingathome/ChangeLog b/app-sci/foldingathome/ChangeLog
new file mode 100644
index 000000000000..741e4de9eb7e
--- /dev/null
+++ b/app-sci/foldingathome/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/foldingathome
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.1 2002/11/04 13:25:17 aliz Exp $
+
+*foldingathome-3.14 (04 Nov 2002)
+
+ 04 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuild contributed by Ryan Shaw <ryan.shaw@stanfordalumni.org> in #9535.
diff --git a/app-sci/foldingathome/files/digest-foldingathome-3.14 b/app-sci/foldingathome/files/digest-foldingathome-3.14
new file mode 100644
index 000000000000..df8b62ecf9aa
--- /dev/null
+++ b/app-sci/foldingathome/files/digest-foldingathome-3.14
@@ -0,0 +1 @@
+MD5 3d72bb1276a9eab637cc54b87bbc1615 FAH3Console-Linux.exe 608912
diff --git a/app-sci/foldingathome/files/folding-init.d b/app-sci/foldingathome/files/folding-init.d
new file mode 100644
index 000000000000..2a6dc5b3898e
--- /dev/null
+++ b/app-sci/foldingathome/files/folding-init.d
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+
+start() {
+
+ ebegin "Starting Folding@home"
+ cd /opt/foldingathome
+ ./foldingathome >&/dev/null&
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Folding@home"
+ killall foldingathome
+ eend $?
+}
+
diff --git a/app-sci/foldingathome/foldingathome-3.14.ebuild b/app-sci/foldingathome/foldingathome-3.14.ebuild
new file mode 100644
index 000000000000..8f0192517aca
--- /dev/null
+++ b/app-sci/foldingathome/foldingathome-3.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/foldingathome-3.14.ebuild,v 1.1 2002/11/04 13:25:17 aliz Exp $
+
+S=${WORKDIR}/${P}
+
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I="/opt/foldingathome"
+
+DESCRIPTION="Help simulate protein folding at home"
+HOMEPAGE="http://folding.stanford.edu/"
+SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH3Console-Linux.exe"
+
+DEPEND=">=sys-apps/baselayout-1.8.0"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_unpack () {
+ mkdir ${P}
+ cp ${DISTDIR}/FAH3Console-Linux.exe ${P}
+}
+
+src_install () {
+ exeinto ${I} ; newexe FAH3Console-Linux.exe foldingathome
+ exeinto /etc/init.d ; newexe ${FILESDIR}/folding-init.d foldingathome
+}
+
+pkg_postinst () {
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+}
+
+pkg_postrm () {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}
+