summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-07-13 03:42:20 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-07-13 03:42:20 +0000
commit91c96b95aa1b7f76f5ed24f041185a472b0663c6 (patch)
treef8df14b3e26f49c2c21341f15be58b41f97ac73d /app-sci
parentstable on ppc64, bug #55324 (Manifest recommit) (diff)
downloadgentoo-2-91c96b95aa1b7f76f5ed24f041185a472b0663c6.tar.gz
gentoo-2-91c96b95aa1b7f76f5ed24f041185a472b0663c6.tar.bz2
gentoo-2-91c96b95aa1b7f76f5ed24f041185a472b0663c6.zip
added filtering of CFLAGS for g77
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/lapack-atlas/ChangeLog6
-rw-r--r--app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/app-sci/lapack-atlas/ChangeLog b/app-sci/lapack-atlas/ChangeLog
index c2c05e82ad30..be75d85c7069 100644
--- a/app-sci/lapack-atlas/ChangeLog
+++ b/app-sci/lapack-atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/lapack-atlas
# Copyright 2004-2004 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/ChangeLog,v 1.11 2004/07/04 22:48:23 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/ChangeLog,v 1.12 2004/07/13 03:42:20 george Exp $
+
+ 12 Jul 2004; George Shapovalov <george@gentoo.org> lapack-atlas-3.6.0.ebuild :
+ added filtering of CFLAGS for g77 (#56265),
+ thanks to Sourav Mandal <sourav@sourav.net> for suggestion.
04 Jul 2004; Ferris McCormick <fmccor@gentoo.org> lapack-atlas-3.6.0.ebuild:
Add (missed) ~sparc keyword.
diff --git a/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild b/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
index 1408b0770ec5..beb956a63041 100644
--- a/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
+++ b/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.10 2004/07/04 22:48:23 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack-atlas/lapack-atlas-3.6.0.ebuild,v 1.11 2004/07/13 03:42:20 george Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Full LAPACK implementation using available ATLAS routines"
HOMEPAGE="http://math-atlas.sourceforge.net/"
@@ -126,6 +126,10 @@ src_compile() {
# routines to determine machine constants.
else
FC="g77"
+ # g77 hates opts, esp. machine-specific
+ ALLOWED_FLAGS="-O -O1 -O2 -fstack-protector -fno-unit-at-a-time \
+ -pipe -g -Wall"
+ strip-flags
FFLAGS="${CFLAGS}"
NOOPT=""
fi