summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-10 08:20:41 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-10 08:20:41 +0000
commit8da830dba21010ff57722894b4da00d0da407833 (patch)
tree400587684652a65c5826b97ddbe6a0653c2ad361 /app-sci
parentCleanup, bump to stable (Manifest recommit) (diff)
downloadgentoo-2-8da830dba21010ff57722894b4da00d0da407833.tar.gz
gentoo-2-8da830dba21010ff57722894b4da00d0da407833.tar.bz2
gentoo-2-8da830dba21010ff57722894b4da00d0da407833.zip
little sed and epatch fixes
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r2.ebuild8
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r3.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/app-sci/netcdf/netcdf-3.5.0-r2.ebuild b/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
index 713242c346c6..42e73bc7f9d6 100644
--- a/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
+++ b/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r2.ebuild,v 1.6 2004/02/22 19:53:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r2.ebuild,v 1.7 2004/03/10 08:20:41 phosphan Exp $
DESCRIPTION="Scientific library and interface for array oriented data access"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
@@ -16,12 +16,12 @@ src_unpack() {
unpack ${A}
cd ${S}
# welcome to ANSI C++ coding with sed
- cp configure configure~ && sed \
+ sed \
-e 's/iostream\.h/iostream/g' \
-e 's/cout/std::cout/g' \
- -e 's/^extern "C".*//g' <configure~ >configure || die
+ -e 's/^extern "C".*//g' -i configure || die
- cd cxx && patch -p1 <${FILESDIR}/gcc3-gentoo.patch || die
+ cd cxx && epatch ${FILESDIR}/gcc3-gentoo.patch
}
src_compile() {
diff --git a/app-sci/netcdf/netcdf-3.5.0-r3.ebuild b/app-sci/netcdf/netcdf-3.5.0-r3.ebuild
index 65430f45b555..004ccc48d271 100644
--- a/app-sci/netcdf/netcdf-3.5.0-r3.ebuild
+++ b/app-sci/netcdf/netcdf-3.5.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r3.ebuild,v 1.7 2004/03/03 13:37:45 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r3.ebuild,v 1.8 2004/03/10 08:20:41 phosphan Exp $
DESCRIPTION="Scientific library and interface for array oriented data access"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
@@ -16,12 +16,12 @@ src_unpack() {
unpack ${A}
cd ${S}
# welcome to ANSI C++ coding with sed
- cp configure configure~ && sed \
+ sed \
-e 's/iostream\.h/iostream/g' \
-e 's/cout/std::cout/g' \
- -e 's/^extern "C".*//g' <configure~ >configure || die
+ -e 's/^extern "C".*//g' -i configure || die
- cd cxx && patch -p1 <${FILESDIR}/gcc3-gentoo.patch || die
+ cd cxx && epatch ${FILESDIR}/gcc3-gentoo.patch
}
src_compile() {