summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-09-23 08:23:14 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-09-23 08:23:14 +0000
commit881cc1865a6c8bece79591f0a9a4d5d75e63907f (patch)
tree50a82780a0040607fcb23278f17fa39acaba0887 /app-sci
parentPull old versions. (Manifest recommit) (diff)
downloadgentoo-2-881cc1865a6c8bece79591f0a9a4d5d75e63907f.tar.gz
gentoo-2-881cc1865a6c8bece79591f0a9a4d5d75e63907f.tar.bz2
gentoo-2-881cc1865a6c8bece79591f0a9a4d5d75e63907f.zip
Update blas and lapack dependencies to the virtuals. This requires a revision bump to fix some issues (#54596, #64200).
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/mpqc/ChangeLog8
-rw-r--r--app-sci/mpqc/files/digest-mpqc-2.2.2-r12
-rw-r--r--app-sci/mpqc/mpqc-2.2.2-r1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/app-sci/mpqc/ChangeLog b/app-sci/mpqc/ChangeLog
index 644e95891ef7..2d71f7c19bb4 100644
--- a/app-sci/mpqc/ChangeLog
+++ b/app-sci/mpqc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/mpqc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.12 2004/09/23 08:13:05 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.13 2004/09/23 08:23:14 spyderous Exp $
+
+*mpqc-2.2.2-r1 (23 Sep 2004)
+
+ 23 Sep 2004; Donnie Berkholz <spyderous@gentoo.org>; +mpqc-2.2.2-r1.ebuild:
+ Update blas and lapack dependencies to the virtuals. This requires a revision
+ bump to fix some issues (#54596, #64200).
23 Sep 2004; Donnie Berkholz <spyderous@gentoo.org>; -mpqc-2.1.2.ebuild,
-mpqc-2.2.0.ebuild:
diff --git a/app-sci/mpqc/files/digest-mpqc-2.2.2-r1 b/app-sci/mpqc/files/digest-mpqc-2.2.2-r1
new file mode 100644
index 000000000000..86aa62626884
--- /dev/null
+++ b/app-sci/mpqc/files/digest-mpqc-2.2.2-r1
@@ -0,0 +1,2 @@
+MD5 7f5d2e6340aa9eba76a6e37cebc5fb9d mpqc-2.2.2.tar.gz 2061755
+MD5 2602c914c9181e92c77153ce21e13116 mpqc-man-2.2.2.tar.gz 166450
diff --git a/app-sci/mpqc/mpqc-2.2.2-r1.ebuild b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..44e03dabe802
--- /dev/null
+++ b/app-sci/mpqc/mpqc-2.2.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.2.2-r1.ebuild,v 1.1 2004/09/23 08:23:14 spyderous Exp $
+
+DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
+HOMEPAGE="http://www.mpqc.org/"
+SRC_URI="mirror://sourceforge/mpqc/${P}.tar.gz
+ doc? ( mirror://sourceforge/mpqc/${PN}-man-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Should work on x86, amd64 and ppc, at least
+KEYWORDS="~x86"
+IUSE="doc X"
+
+DEPEND="sys-devel/flex
+ virtual/blas
+ virtual/lapack
+ dev-lang/perl
+ X? ( virtual/x11 )"
+
+src_compile() {
+ CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
+ myconf="${myconf} --prefix=/usr"
+ use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib"
+ ./configure ${myconf}
+ sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
+ lib/LocalMakefile > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ emake
+}
+
+src_install() {
+ sed -e "s:^prefix=.*$:prefix=${D}/usr:" lib/LocalMakefile \
+ > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
+ make install install_devel install_inc
+}