summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-15 13:10:53 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-15 13:10:53 +0000
commit7f58ab2e9f8cf4f5f0f1dcb2b2922a8f0be54965 (patch)
tree52bce1093c14190e6d351a49b7fed292b7698a74 /app-sci
parentx86 unmask (Manifest recommit) (diff)
downloadgentoo-2-7f58ab2e9f8cf4f5f0f1dcb2b2922a8f0be54965.tar.gz
gentoo-2-7f58ab2e9f8cf4f5f0f1dcb2b2922a8f0be54965.tar.bz2
gentoo-2-7f58ab2e9f8cf4f5f0f1dcb2b2922a8f0be54965.zip
Fixed bug #37409
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/qmatplot/ChangeLog9
-rw-r--r--app-sci/qmatplot/Manifest2
-rw-r--r--app-sci/qmatplot/files/digest-qmatplot-0.4.2-r11
-rw-r--r--app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild34
4 files changed, 44 insertions, 2 deletions
diff --git a/app-sci/qmatplot/ChangeLog b/app-sci/qmatplot/ChangeLog
index 594df55586f6..7e6c3dbb91c0 100644
--- a/app-sci/qmatplot/ChangeLog
+++ b/app-sci/qmatplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/qmatplot
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/ChangeLog,v 1.2 2004/01/04 02:12:59 caleb Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/ChangeLog,v 1.3 2004/03/15 13:10:52 phosphan Exp $
+
+*qmatplot-0.4.2-r1 (15 Mar 2004)
+
+ 15 Mar 2004; Patrick Kursawe <phosphan@gentoo.org> qmatplot-0.4.2-r1.ebuild:
+ Fixed bug #37409
03 Jan 2004; Caleb Tennis <caleb@gentoo.org> qmatplot-0.4.2.ebuild:
Remove need-qt, add it directly as a dep
diff --git a/app-sci/qmatplot/Manifest b/app-sci/qmatplot/Manifest
index 96acb3f2f85e..e5dad8a05b80 100644
--- a/app-sci/qmatplot/Manifest
+++ b/app-sci/qmatplot/Manifest
@@ -1,5 +1,7 @@
MD5 c7f2854f4abf19b340013d134e6f4ced qmatplot-0.4.2.ebuild 705
+MD5 1eba754e21da19cef27e2d29735128af qmatplot-0.4.2-r1.ebuild 743
MD5 1578d14efa908f5c359275de43cd91df ChangeLog 579
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 caa148371a7c466ed0b1c5c95b929622 files/qmatplot-0.4.2-gentoo.patch 453
MD5 2cbaba30419f14241d64b9569438428f files/digest-qmatplot-0.4.2 64
+MD5 2cbaba30419f14241d64b9569438428f files/digest-qmatplot-0.4.2-r1 64
diff --git a/app-sci/qmatplot/files/digest-qmatplot-0.4.2-r1 b/app-sci/qmatplot/files/digest-qmatplot-0.4.2-r1
new file mode 100644
index 000000000000..f2d5fc23f9b8
--- /dev/null
+++ b/app-sci/qmatplot/files/digest-qmatplot-0.4.2-r1
@@ -0,0 +1 @@
+MD5 37bcbb7b822b744b189ed5fceb751755 qmatplot-0.4.2.tgz 1145773
diff --git a/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild b/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..48c662442139
--- /dev/null
+++ b/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild,v 1.1 2004/03/15 13:10:52 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="gnuplot-like tool for plotting data sets in either two or three dimensions"
+HOMEPAGE="http://qmatplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/qt-3
+ >=app-sci/octave-2.1
+ >=app-sci/scilab-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ addwrite "${QTDIR}/etc/settings"
+ econf || die "configure failed"
+ emake QSETTINGSDIR="${QTDIR}/etc/settings/" || die "make failed"
+}
+
+src_install() {
+ make QSETTINGSDIR="${D}/${QTDIR}/etc/settings/" DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog AUTHORS
+}