summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-03-09 20:29:43 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-03-09 20:29:43 +0000
commit4aa76ecff911ebe15a776dd4f5ecfd92c62ffdcd (patch)
treec3689b3f614f86141682f3fe7c611d8be0f47a73 /app-sci
parentVersion bump (diff)
downloadgentoo-2-4aa76ecff911ebe15a776dd4f5ecfd92c62ffdcd.tar.gz
gentoo-2-4aa76ecff911ebe15a776dd4f5ecfd92c62ffdcd.tar.bz2
gentoo-2-4aa76ecff911ebe15a776dd4f5ecfd92c62ffdcd.zip
new version, fixups to building
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/iverilog/ChangeLog8
-rw-r--r--app-sci/iverilog/files/digest-iverilog-0.71
-rw-r--r--app-sci/iverilog/iverilog-0.7.ebuild32
3 files changed, 40 insertions, 1 deletions
diff --git a/app-sci/iverilog/ChangeLog b/app-sci/iverilog/ChangeLog
index 1119a104f287..bb59cdb5d54a 100644
--- a/app-sci/iverilog/ChangeLog
+++ b/app-sci/iverilog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/iverilog
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/iverilog/ChangeLog,v 1.4 2003/02/12 05:16:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/iverilog/ChangeLog,v 1.5 2003/03/09 20:29:43 george Exp $
+
+*iverilog-0.7 (09 Mar 2003)
+
+ 09 Mar 2003; George Shapovalov <george@gentoo.org> iverilog-0.7.ebuild :
+ new version (14900)
+ some updates to fix compilation, thanks to Justin Huff <jjhuff@mspin.net>
*icarus_verilog-0.6.1 (4/3/2002)
diff --git a/app-sci/iverilog/files/digest-iverilog-0.7 b/app-sci/iverilog/files/digest-iverilog-0.7
new file mode 100644
index 000000000000..58bc8112e29d
--- /dev/null
+++ b/app-sci/iverilog/files/digest-iverilog-0.7
@@ -0,0 +1 @@
+MD5 c8f09bc061e890242d39b9afc8e69698 verilog-0.7.tar.gz 846998
diff --git a/app-sci/iverilog/iverilog-0.7.ebuild b/app-sci/iverilog/iverilog-0.7.ebuild
new file mode 100644
index 000000000000..91acd817a3ab
--- /dev/null
+++ b/app-sci/iverilog/iverilog-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/iverilog/iverilog-0.7.ebuild,v 1.1 2003/03/09 20:29:43 george Exp $
+
+IUSE=""
+
+S="${WORKDIR}/verilog-${PV}"
+
+DESCRIPTION="A Verilog simulation and synthesis tool"
+SRC_URI="ftp://icarus.com/pub/eda/verilog/v0.7/verilog-${PV}.tar.gz"
+HOMEPAGE="http://www.icarus.com/eda/verilog/"
+
+DEPEND="dev-util/gperf"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+src_compile() {
+ econf || "./configure failed"
+ emake || "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc *.txt COPYING INSTALL examples/*
+}