summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-10 07:03:08 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-10 07:03:08 +0000
commit43064df4a4bf6902a2f52e6536ce652179d3bcb5 (patch)
treeb26d8961ba1916a71458cc1b51567db2e6572520 /app-sci
parentadded the local USE flags cln and gsl and made the former local USE flag (diff)
downloadgentoo-2-43064df4a4bf6902a2f52e6536ce652179d3bcb5.tar.gz
gentoo-2-43064df4a4bf6902a2f52e6536ce652179d3bcb5.tar.bz2
gentoo-2-43064df4a4bf6902a2f52e6536ce652179d3bcb5.zip
New version intruducing several USE flags
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/orsa/ChangeLog9
-rw-r--r--app-sci/orsa/Manifest2
-rw-r--r--app-sci/orsa/files/digest-orsa-0.5.0_rc21
-rw-r--r--app-sci/orsa/orsa-0.5.0_rc2.ebuild65
4 files changed, 75 insertions, 2 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
index 37bc96194b69..7a9940013005 100644
--- a/app-sci/orsa/ChangeLog
+++ b/app-sci/orsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/orsa
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.4 2003/10/01 06:25:37 george Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.5 2004/03/10 07:03:08 phosphan Exp $
+
+*orsa-0.5.0_rc2 (10 Mar 2004)
+
+ 10 Mar 2004; Patrick Kursawe <phosphan@gentoo.org> orsa-0.5.0_rc2.ebuild:
+ New version, intruduced ginac/gsl/fftw/qt/mpi USE flag usage.
*orsa-0.3.1 (30 Sep 2003)
diff --git a/app-sci/orsa/Manifest b/app-sci/orsa/Manifest
index 5e2aa910c093..3c3fa21ec7ce 100644
--- a/app-sci/orsa/Manifest
+++ b/app-sci/orsa/Manifest
@@ -1,4 +1,5 @@
MD5 df081c05a631076ac52fb9f71f44553d orsa-0.3.0_rc1.ebuild 967
+MD5 8ac7e9b897d998dd2530f7a53ed56345 orsa-0.5.0_rc2.ebuild 923
MD5 11906580c433eae53ac5b6ed63ed6ef6 orsa-0.3.0_rc3.ebuild 797
MD5 9a4ed615310a17e0b114193c567a972a orsa-0.3.1.ebuild 751
MD5 62cfbddc10cdae64529cccc71a9a3f7a ChangeLog 1170
@@ -6,3 +7,4 @@ MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 4ac11cc803cd2a23ab9da8490d841e7c files/digest-orsa-0.3.0_rc1 66
MD5 9a419b528b36565c111576fcc7dfaa7c files/digest-orsa-0.3.0_rc3 66
MD5 38ab5f417512fb8637bffdfb874be99c files/digest-orsa-0.3.1 62
+MD5 d07e1ada42ab073d4c6af277c950d8d5 files/digest-orsa-0.5.0_rc2 66
diff --git a/app-sci/orsa/files/digest-orsa-0.5.0_rc2 b/app-sci/orsa/files/digest-orsa-0.5.0_rc2
new file mode 100644
index 000000000000..958e5d98e5d6
--- /dev/null
+++ b/app-sci/orsa/files/digest-orsa-0.5.0_rc2
@@ -0,0 +1 @@
+MD5 f25173bb803b122870973c28c7ecad20 orsa-0.5.0-rc2.tar.gz 729142
diff --git a/app-sci/orsa/orsa-0.5.0_rc2.ebuild b/app-sci/orsa/orsa-0.5.0_rc2.ebuild
new file mode 100644
index 000000000000..0fc863b6f0b2
--- /dev/null
+++ b/app-sci/orsa/orsa-0.5.0_rc2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.5.0_rc2.ebuild,v 1.1 2004/03/10 07:03:08 phosphan Exp $
+
+inherit base flag-o-matic
+
+DESCRIPTION="Orbital Reconstruction, Simulation and Analysis"
+HOMEPAGE="http://orsa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/orsa/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mpi fftw ginac cln gsl qt"
+
+S="${WORKDIR}/${P/_/-}"
+
+DEPEND="virtual/glibc
+ fftw? ( =dev-libs/fftw-2.1* )
+ >=dev-libs/gsl-1.3
+ qt? ( >=x11-libs/qt-3.2 )
+ >=sys-libs/readline-4.2
+ mpi? ( sys-cluster/lam-mpi )
+ ginac? ( app-sci/ginac )
+ gsl? ( dev-libs/gsl )
+ cln? ( dev-libs/cln )"
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+src_compile() {
+ if ! use mpi; then
+ export MPICXX="g++"
+ fi
+ local myconf
+ if ! use ginac; then
+ myconf="--with-ginac-prefix=/no/such/file"
+ fi
+ if ! use gsl; then
+ myconf="${myconf} --with-gsl-prefix=/no/such/file"
+ fi
+ if ! use cln; then
+ myconf="${myconf} --with-cln-prefix=/no/such/file"
+ fi
+ if ! use fftw; then
+ sed -e 's/have_fftw=yes/have_fftw=no/' -i configure
+ fi
+ if ! use qt; then
+ myconf="${myconf} --with-qt-dir=/no/such/file"
+ fi
+ econf ${myconf} $(use_with opengl gl) || die "configure failed"
+ if use mpi; then
+ sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread/' \
+ -i src/orsa/Makefile
+ fi
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ dodoc src/test/*
+}