summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-04-27 23:49:22 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-04-27 23:49:22 +0000
commit25c45023db0e5c1b05abe1085dfb2341281008b0 (patch)
tree75f0567bd943085ab6d2571ce9d978f197a2a7f9 /app-sci
parentversion bump (diff)
downloadgentoo-2-25c45023db0e5c1b05abe1085dfb2341281008b0.tar.gz
gentoo-2-25c45023db0e5c1b05abe1085dfb2341281008b0.tar.bz2
gentoo-2-25c45023db0e5c1b05abe1085dfb2341281008b0.zip
added new category - app-sci
added gromacs to this category
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/gromacs/ChangeLog9
-rw-r--r--app-sci/gromacs/files/digest-gromacs-3.1.31
-rw-r--r--app-sci/gromacs/gromacs-3.1.3.ebuild39
3 files changed, 49 insertions, 0 deletions
diff --git a/app-sci/gromacs/ChangeLog b/app-sci/gromacs/ChangeLog
new file mode 100644
index 000000000000..9267e67340f4
--- /dev/null
+++ b/app-sci/gromacs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-sci/gromacs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.2 2002/04/27 23:08:36 bangert Exp
+
+*gromacs-3.1.3 (27 Apr 2002)
+
+ 27 Apr 2002; G.Shapovalov <georges@its.caltech.edu> all_files :
+
+ initial release.
diff --git a/app-sci/gromacs/files/digest-gromacs-3.1.3 b/app-sci/gromacs/files/digest-gromacs-3.1.3
new file mode 100644
index 000000000000..e1bf3c7de050
--- /dev/null
+++ b/app-sci/gromacs/files/digest-gromacs-3.1.3
@@ -0,0 +1 @@
+MD5 6e6a167075d1138e0cf98601a8f0608b gromacs-3.1.3.tar.gz 2656833
diff --git a/app-sci/gromacs/gromacs-3.1.3.ebuild b/app-sci/gromacs/gromacs-3.1.3.ebuild
new file mode 100644
index 000000000000..bbb6111d617a
--- /dev/null
+++ b/app-sci/gromacs/gromacs-3.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <george@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+DESCRIPTION="The ultimate Molecular Dynamics simulation package"
+
+SRC_URI="ftp://ftp.gromacs.org/pub/gromacs/${P}.tar.gz"
+
+HOMEPAGE="http://www.gromacs.org/"
+
+DEPEND="mpi? ( >=lam-6.5.2 )
+ >=fftw-2.1.3
+ >=sys-devel/binutils-2.10.91.0.2"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/gromacs \
+ --includedir=/usr/include/gromacs \
+ --infodir=/usr/share/info \
+ --enable-fortran \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL README
+
+ #move html docs under /usr/share/doc
+ #and leave examples and templates under /usr/gromacs...
+ mv ${D}/usr/gromacs/share/html ${D}/usr/share/doc/${P}
+
+}