summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-06-19 14:04:29 +0000
committerPeter Johanson <latexer@gentoo.org>2003-06-19 14:04:29 +0000
commit1d20d847cc7e51a8c1f0da0ed40b83600c0329bf (patch)
tree61294a95bf159693afe6cf8f88199db5b9c6e379 /app-sci
parentBump and mark 0.8.8a stable (diff)
downloadgentoo-2-1d20d847cc7e51a8c1f0da0ed40b83600c0329bf.tar.gz
gentoo-2-1d20d847cc7e51a8c1f0da0ed40b83600c0329bf.tar.bz2
gentoo-2-1d20d847cc7e51a8c1f0da0ed40b83600c0329bf.zip
Bump and mark 0.8.8a stable
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/epix/ChangeLog8
-rw-r--r--app-sci/epix/Manifest6
-rw-r--r--app-sci/epix/epix-0.8.10a.ebuild58
-rw-r--r--app-sci/epix/epix-0.8.8a.ebuild4
-rw-r--r--app-sci/epix/files/digest-epix-0.8.10a1
5 files changed, 71 insertions, 6 deletions
diff --git a/app-sci/epix/ChangeLog b/app-sci/epix/ChangeLog
index fe47c7cddd10..edd8fbaa2ac6 100644
--- a/app-sci/epix/ChangeLog
+++ b/app-sci/epix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/epix
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/ChangeLog,v 1.3 2003/05/09 18:33:49 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/ChangeLog,v 1.4 2003/06/19 14:04:24 latexer Exp $
+
+*epix-0.8.10a (19 Jun 2003)
+
+ 19 Jun 2003; Peter Johanson <latexer@gentoo.org> epix-0.8.10a.ebuild,
+ epix-0.8.8a.ebuild:
+ Bump, and marking 0.8.8a as stable
09 May 2003; Peter Johanson <latexer@gentoo.org> epix-0.8.8a.ebuild:
Add some sedding for bug #20633
diff --git a/app-sci/epix/Manifest b/app-sci/epix/Manifest
index c0c574e1a34e..b256f4e6440f 100644
--- a/app-sci/epix/Manifest
+++ b/app-sci/epix/Manifest
@@ -1,5 +1,5 @@
-MD5 df30e465f196ddcdfe0151c041ca1963 epix-0.8.10a.ebuild 1429
-MD5 55e3cd2bd7baebc62d26ef7c8ec7dc28 epix-0.8.8a.ebuild 1407
-MD5 580b474aca0d1d5259949c048c612e4a ChangeLog 471
+MD5 d64e9cba50e4b0c97fe9f16fbc2a5606 epix-0.8.10a.ebuild 1430
+MD5 1dcf9398c082cf22042bb8fa40767e60 epix-0.8.8a.ebuild 1406
+MD5 a31661a5785c9f20e70157c86a7abbd3 ChangeLog 632
MD5 ae88d4a56838f5e3dda1e25e01c00cad files/digest-epix-0.8.10a 68
MD5 41dfe0820d6f9ceace8a163fa437d246 files/digest-epix-0.8.8a 67
diff --git a/app-sci/epix/epix-0.8.10a.ebuild b/app-sci/epix/epix-0.8.10a.ebuild
new file mode 100644
index 000000000000..794c41b5ef8e
--- /dev/null
+++ b/app-sci/epix/epix-0.8.10a.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/epix-0.8.10a.ebuild,v 1.1 2003/06/19 14:04:24 latexer Exp $
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+
+SRC_URI="http://mathcs.holycross.edu/~ahwang/software/${P}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="app-shells/bash"
+
+S=${WORKDIR}/${P/a/}
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Some sedding to get things installed in the proper places.
+
+ mv Makefile ${T}
+ sed -e "s:CXX=g++:CXX=${CXX}:" \
+ -e "s:CFLAGS=-c -Wall:CFLAGS=-c -Wall ${CFLAGS}:" \
+ -e "s:prefix=/usr/local:prefix=${D}/usr:" \
+ -e "s:share/epix:share/${P}:" \
+ -e "s:/man/man1:/share/man/man1:" \
+ ${T}/Makefile > Makefile
+
+ mv helpfiles.sh ${T}
+ sed -e "s:\${EPIX_SHAREDIR}/epix:\${EPIX_SHAREDIR}/${P}:" \
+ ${T}/helpfiles.sh > helpfiles.sh
+ chmod a+x helpfiles.sh
+
+ mv pre-install.sh ${T}
+ sed -e "s:man man/man1 share:share share/man share/man/man1:" \
+ -e "s:share/epix:share/${P}:g" \
+ ${T}/pre-install.sh > pre-install.sh
+ chmod a+x pre-install.sh
+
+ mv -f prepix ${T}
+ sed -e "s:^INSTALL_DIR.*:INSTALL_DIR=/usr:" \
+ ${T}/prepix > prepix
+ chmod a+x prepix
+}
+
+src_compile() {
+ emake || die
+ emake contrib ||die
+}
+
+src_install() {
+ make install || die
+}
diff --git a/app-sci/epix/epix-0.8.8a.ebuild b/app-sci/epix/epix-0.8.8a.ebuild
index 2d39de7a28f7..91345cfa15a1 100644
--- a/app-sci/epix/epix-0.8.8a.ebuild
+++ b/app-sci/epix/epix-0.8.8a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/epix-0.8.8a.ebuild,v 1.4 2003/05/09 18:33:49 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/epix-0.8.8a.ebuild,v 1.5 2003/06/19 14:04:24 latexer Exp $
DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
@@ -9,7 +9,7 @@ SRC_URI="http://mathcs.holycross.edu/~ahwang/software/${P}_src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="app-shells/bash"
diff --git a/app-sci/epix/files/digest-epix-0.8.10a b/app-sci/epix/files/digest-epix-0.8.10a
new file mode 100644
index 000000000000..39ba4c10e3e4
--- /dev/null
+++ b/app-sci/epix/files/digest-epix-0.8.10a
@@ -0,0 +1 @@
+MD5 0c3bda1c852c2e398a0c56fae511cda9 epix-0.8.10a_src.tar.gz 149125