summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-08-15 13:03:57 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-08-15 13:03:57 +0000
commit15cd20ebc4637700708b16062ac60d76ee5b5912 (patch)
tree32c27f91c45b7fc6d187f7201485693b37f2dd68 /app-sci
parenta patch to make it build nicely on gcc 3.3.1 (diff)
downloadgentoo-2-15cd20ebc4637700708b16062ac60d76ee5b5912.tar.gz
gentoo-2-15cd20ebc4637700708b16062ac60d76ee5b5912.tar.bz2
gentoo-2-15cd20ebc4637700708b16062ac60d76ee5b5912.zip
a patch to make it build nicely on gcc 3.3.1
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/units/ChangeLog8
-rw-r--r--app-sci/units/Manifest4
-rw-r--r--app-sci/units/files/digest-units-1.74-r11
-rw-r--r--app-sci/units/files/remove-script.patch21
-rw-r--r--app-sci/units/units-1.74-r1.ebuild31
5 files changed, 62 insertions, 3 deletions
diff --git a/app-sci/units/ChangeLog b/app-sci/units/ChangeLog
index 5fb5308709ab..ec32ea681fca 100644
--- a/app-sci/units/ChangeLog
+++ b/app-sci/units/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/units
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/units/ChangeLog,v 1.5 2003/03/20 21:09:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/units/ChangeLog,v 1.6 2003/08/15 13:03:48 spider Exp $
+
+*units-1.74-r1 (15 Aug 2003)
+
+ 15 Aug 2003; <spider@gentoo.org> units-1.74-r1.ebuild,
+ files/remove-script.patch:
+ A small patch to remove a script at the end that bugged out with gcc 3.3.1
*units-1.74 (1 Feb 2002)
diff --git a/app-sci/units/Manifest b/app-sci/units/Manifest
index eb93667fc001..1bc16c12c975 100644
--- a/app-sci/units/Manifest
+++ b/app-sci/units/Manifest
@@ -1,7 +1,7 @@
MD5 acf413ae7252fbb36880972142018ab4 units-1.74.ebuild 739
-MD5 279edd078d1bfac56a63702ee6a887f0 ChangeLog 935
+MD5 3605625f547fb89ad40cdf6fe6d84b2c ChangeLog 1127
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 1f864534f7960b2d9e66339c0cbdaabf units-1.74-r1.ebuild 820
+MD5 ea33f3c365d2e75e3bf6e38b18071961 units-1.74-r1.ebuild 820
MD5 d448f4425b2a1fcaf2964dcae3089b30 files/digest-units-1.74 62
MD5 454866fde7edeaf67e6e6db4956c7953 files/remove-script.patch 460
MD5 d448f4425b2a1fcaf2964dcae3089b30 files/digest-units-1.74-r1 62
diff --git a/app-sci/units/files/digest-units-1.74-r1 b/app-sci/units/files/digest-units-1.74-r1
new file mode 100644
index 000000000000..066a3128baa5
--- /dev/null
+++ b/app-sci/units/files/digest-units-1.74-r1
@@ -0,0 +1 @@
+MD5 230d1cb0367f9f4ac345beda371bbb53 units-1.74.tar.gz 178224
diff --git a/app-sci/units/files/remove-script.patch b/app-sci/units/files/remove-script.patch
new file mode 100644
index 000000000000..ad99a97cc2e5
--- /dev/null
+++ b/app-sci/units/files/remove-script.patch
@@ -0,0 +1,21 @@
+--- units.c.old 2003-08-15 13:47:25.881457784 +0200
++++ units.c 2003-08-15 13:47:08.096161560 +0200
+@@ -2324,11 +2324,11 @@
+ crude example to convert lines in a file 'feet' from ft to m might be:
+ */
+
+-#if 0
+-
+- "sed 's/.*/& ft\"
+- "m/' feet|units -q|sed 's/^[[:space:]]*\* //"
+- "/^[[:space:]]*\//d'"
+-
+-#endif
++// #if 0
++//
++// "sed 's/.*/& ft\"
++// "m/' feet|units -q|sed 's/^[[:space:]]*\* //"
++// "/^[[:space:]]*\//d'"
++//
++// #endif
+
diff --git a/app-sci/units/units-1.74-r1.ebuild b/app-sci/units/units-1.74-r1.ebuild
new file mode 100644
index 000000000000..3c78810bbeeb
--- /dev/null
+++ b/app-sci/units/units-1.74-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/units/units-1.74-r1.ebuild,v 1.1 2003/08/15 13:03:48 spider Exp $
+
+DESCRIPTION="program for units conversion and units calculation"
+SRC_URI="ftp://ftp.gnu.org/gnu/units/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc alpha"
+
+DEPEND=">=sys-libs/readline-4.1-r2
+ >=sys-libs/ncurses-5.2-r3"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/remove-script.patch
+}
+
+src_compile() {
+ #Note: the trailing / is required in the datadir path.
+ econf --datadir=/usr/share/${PN}/ || die
+ emake || die
+}
+
+src_install() {
+ einstall datadir=${D}/usr/share/${PN}/ || die
+ dodoc ChangeLog NEWS README
+}