summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 04:17:04 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 04:17:04 +0000
commitf84d4ccf1fea1eb8c27dbf9c997c71744950b653 (patch)
tree5e5a94797f5a5277b07508609b559c657a201cf6 /app-sci/scilab
parent~mips (Manifest recommit) (diff)
downloadgentoo-2-f84d4ccf1fea1eb8c27dbf9c997c71744950b653.tar.gz
gentoo-2-f84d4ccf1fea1eb8c27dbf9c997c71744950b653.tar.bz2
gentoo-2-f84d4ccf1fea1eb8c27dbf9c997c71744950b653.zip
QA - fix use invocation
Diffstat (limited to 'app-sci/scilab')
-rw-r--r--app-sci/scilab/ChangeLog6
-rw-r--r--app-sci/scilab/scilab-2.7-r3.ebuild4
-rw-r--r--app-sci/scilab/scilab-2.7.ebuild12
3 files changed, 13 insertions, 9 deletions
diff --git a/app-sci/scilab/ChangeLog b/app-sci/scilab/ChangeLog
index ad56916b6452..7bcb68c20a12 100644
--- a/app-sci/scilab/ChangeLog
+++ b/app-sci/scilab/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/scilab
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.17 2004/06/24 22:16:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.18 2004/06/28 04:17:04 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> scilab-2.7-r3.ebuild,
+ scilab-2.7.ebuild:
+ QA - fix use invocation
14 Jun 2004; Danny van Dyk <kugelfang@gentoo.org> scilab-2.7-r1.ebuild,
scilab-2.7-r3.ebuild:
diff --git a/app-sci/scilab/scilab-2.7-r3.ebuild b/app-sci/scilab/scilab-2.7-r3.ebuild
index 6ca6d6d59992..57462e8bc03a 100644
--- a/app-sci/scilab/scilab-2.7-r3.ebuild
+++ b/app-sci/scilab/scilab-2.7-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7-r3.ebuild,v 1.6 2004/06/24 22:16:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7-r3.ebuild,v 1.7 2004/06/28 04:17:04 agriffis Exp $
inherit virtualx eutils
@@ -35,7 +35,7 @@ pkg_setup() {
ewarn 'Please uninstall it with "emerge unmerge scilab" before continuig'
die
fi
- use ifc || if [ -z `which g77` ]; then
+ if ! use ifc && [ -z `which g77` ]; then
#if ifc is defined then the dep was already checked
eerror "No fortran compiler found on the system!"
eerror "Please add f77 to your USE flags and reemerge gcc!"
diff --git a/app-sci/scilab/scilab-2.7.ebuild b/app-sci/scilab/scilab-2.7.ebuild
index be0f467e3762..255e38ae40b7 100644
--- a/app-sci/scilab/scilab-2.7.ebuild
+++ b/app-sci/scilab/scilab-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7.ebuild,v 1.5 2004/06/24 22:16:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7.ebuild,v 1.6 2004/06/28 04:17:04 agriffis Exp $
DESCRIPTION="scientific software package for numerical computations"
SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/${P}.src.tar.gz"
@@ -13,15 +13,15 @@ IUSE="tcltk"
DEPEND="virtual/x11
x11-libs/Xaw3d
- tcltk? ( dev-lang/tk )"
+ tcltk? ( dev-lang/tk )
+ >=sys-apps/sed-4"
src_compile() {
local myopts
- use tcltk || myopts="--without-tk"
- if [ !"`use tcltk`" ] ; then
- mv ${S}/tcl/Makefile ${S}/tcl/Makefile.orig
- sed -e 's,all:: browsehelpexe,all::,' ${S}/tcl/Makefile.orig > ${S}/tcl/Makefile
+ if ! use tcltk; then
+ myopts="--without-tk"
+ sed -i -e 's,all:: browsehelpexe,all::,' ${S}/tcl/Makefile || die
fi
./configure \