summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-11-30 14:49:56 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-11-30 14:49:56 +0000
commit000ddc1d23c959fe8495fcf424326c2063618b1c (patch)
tree6ae56ef0d327ecbfcddf313fa49fb07bc9218498 /app-sci/scigraphica
parent*** empty log message *** (diff)
downloadgentoo-2-000ddc1d23c959fe8495fcf424326c2063618b1c.tar.gz
gentoo-2-000ddc1d23c959fe8495fcf424326c2063618b1c.tar.bz2
gentoo-2-000ddc1d23c959fe8495fcf424326c2063618b1c.zip
gcc 3.4 patch - bug #71875
Diffstat (limited to 'app-sci/scigraphica')
-rw-r--r--app-sci/scigraphica/ChangeLog6
-rw-r--r--app-sci/scigraphica/files/gcc3.4.patch21
-rw-r--r--app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild10
3 files changed, 35 insertions, 2 deletions
diff --git a/app-sci/scigraphica/ChangeLog b/app-sci/scigraphica/ChangeLog
index 0ad50e602192..52827e4c277c 100644
--- a/app-sci/scigraphica/ChangeLog
+++ b/app-sci/scigraphica/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/scigraphica
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/ChangeLog,v 1.8 2004/06/24 22:16:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/ChangeLog,v 1.9 2004/11/30 14:49:56 phosphan Exp $
+
+ 30 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> +files/gcc3.4.patch,
+ scigraphica-0.8.0-r2.ebuild:
+ gcc 3.4 patch - bug #71875
19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org>
scigraphica-0.8.0-r1.ebuild, scigraphica-0.8.0-r2.ebuild,
diff --git a/app-sci/scigraphica/files/gcc3.4.patch b/app-sci/scigraphica/files/gcc3.4.patch
new file mode 100644
index 000000000000..0a8c392a1738
--- /dev/null
+++ b/app-sci/scigraphica/files/gcc3.4.patch
@@ -0,0 +1,21 @@
+diff -ru src/python/python_config.c src.new/python/python_config.c
+--- src/python/python_config.c 2001-11-30 18:03:23.000000000 +0100
++++ src.new/python/python_config.c 2004-11-30 15:33:59.000000000 +0100
+@@ -235,7 +235,7 @@
+ if (func) func(GTK_WIDGET(widget),&my_var_info[i]);
+ }
+ break;
+- default:
++ default: ;
+ }
+ }
+ #ifdef WITH_GNOME
+@@ -609,7 +609,7 @@
+
+ break;
+
+- default:
++ default:;
+ }
+ }
+
diff --git a/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild b/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild
index 1f26c9128d61..1efc9cdb638f 100644
--- a/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild
+++ b/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild,v 1.4 2004/08/21 15:37:56 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0-r2.ebuild,v 1.5 2004/11/30 14:49:56 phosphan Exp $
+
+inherit eutils
DESCRIPTION="Scientific application for data analysis and technical graphics"
SRC_URI="http://scigraphica.sourceforge.net/src/${P}.tar.gz"
@@ -30,6 +32,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc3.4.patch
+}
+
src_compile() {
#bonobo breaks compile when enabled so it is not enabled for now.
#the result seems to be no printing under gnome.